Reverb not working when assigning geometry

(GhPGame) #1


I’m trying to get the occlusion and reverb effects using the FMOD geometry.
My understanding of FMOD geometry is that when I add the geometer even with the shape of a qube (adding 6 quads and 24 vertices) it shapes the reverb sphere into the geometry such that we get a full reverb environment.
I added 6 quad polygons successfully and put the source inside that box (simulating a room).
I see the occlusion effect (as the listener is outside the room and I set the direct factor to 1, no sound is heard). But what ever I choose for the reverb factor, I hear to reverberation effect.
Is there anything I’m missing hear? Thank you.

(Brett Paterson) #2

The reverb support in geometry is just a means to attenuate the pre-existing reverb that you set with System::createReverb3D. These reverb spheres have a radius and position, and a preset that you can set (ie FMOD_PRESET_GENERIC, FMOD_PRESET_ROOM, FMOD_PRESET_AUDITORIUM etc).

Set a few of these up and it will attenuate the reverb for you based on the geometry. For example, you can confine the reverb into a cube (ie a room), rather than it being a sphere which leaks through walls. It is also good for letting reverb through a doorway (this is called exclusion).

(GhPGame) #3

Thank you. Can I know what is the role of the reverb factor when setting a geometry then?

(Brett Paterson) #4

reverb factor is the amount of reverb you hear based on a line between the listener and the 3d reverb in your scene. If a polygon blocks that line, reverb occlusion lets you know how much reverb you will hear based on that setting.