Feature Request - Play on Stop


(Brett Paterson) #21

the condition to jump to the marker is “parameter is between 0 and 0.99”. If it starts off at 0, it will trigger immediately. This is why it is set to 1.0 to start with.

The AHDSR multiplies that parameter value with the envelope. It is param * 1.0 during the AHDS stage, and when stop is call, it has a downward slope which makes the release go from 1 to 0 quickly. ie when that ADSR hits .99 or .9 or .8 or whatever, now the parameter will be .99 or .9 or .8 or whatever it happens to hit, making the transition region condition trigger, and it will jump to the marker.


(Vojta Nedved) #22

I have similar problem. I designed a sound like this:

It’s sound of a bow shot. First sound is an oneshot, later under loop region there’s scattered sound that keeps playing unless I set the parameter “arrow_release” to 0.5 - 1. Then cursor jumps to Marker A and simultaneously arrow release oneshot sound is played. The problem is whatever I do my event is not released. Usually when there’s nothing to play my events stop automatically without problem but not this time. Do you know what should I do? I suspect loop region to prevent the event from being released. I also tried adding ADSR to arrow_release parameter to no avail.


(Jesse Lyon) #23

See Brett’s solution above, its working perfectly for me. If not, then you likely have your ADSR and condition setup wrong. Also dont forget you have to hold the stop button to audition it properly in FMOD (sending the stop event from the game will set the ADSR to release and jump to the marker automatically during runtime).


(Vojta Nedved) #24

Thanks for your answer. Brett’s solution works for me but it’s not perfect. When I set parameter “arrow_release” to 0.50 weak shot sound can be played, when I set it to 1.00 perfectly strong shot sound can be played. You can’t do this with simple sound on timeline. But that’s not the problem - my problem is that whenever there’s loop region or scattered sound with infinite total sounds, my event doesn’t get released. When I don’t use scattered sound or region loop it gets released normally so I’m a bit confused. Is it some kind of issue of FMOD? Do I have to tell the programmer to stop the event every time after he sets my parameter?


(Vojta Nedved) #25

Or maybe it’s a problem of FMOD studio implementation made by our programmers… I need to evaluate this.