FMOD Studio 2.02 won't start in Jenkins job

Hello! I’m trying to build fmod banks in a jenkins job. I am using this command:

fmodstudiocl.exe -build project.fspro

It used to work when I tested it some time ago, but now it freezes. If I try to start Studio in an RDP session (remote host) it shows the error “loadlibrary failed with error 87 the parameter is incorrect”.
FMOD Studio version 2.02.09. Tried the latest and several older versions. 2.0.22 works out of everything I’ve tried.
I’m assuming this issue is related to Qt. I did a dumpbin /depends for fmodstudiocl.exe and it is linked to fmodstudioui.dll which is linked to Qt libraries.
I tried workarounds for Qt like disabling WDDM driver for RDP in Group Policies and updating graphics driver but it didn helped.
The Jenkins machine is running Windows 10 2H22 19045.2728 with automatic updates enabled.


Unfortunately, I haven’t been able to reproduce your issues. Is there anything particularly non-standard about how you’ve installed Studio on your Jenkins machine? Are you able to run the same command via RDP yourself, and on your local machine, without issue?

As for the “LoadLibrary failed with error 87” issue, if possible, can I get you to provide some more info on your graphics hardware and graphics drivers version? Since you’ve already updated your graphics drivers to no effect, I can’t offer much advice there besides potentially performing a clean reinstall of them, but it’s strange that they would be causing issues - one of our developers has informed me that while there are Qt libs being used in the command line version of Studio, the GUI/GFX related stuff isn’t used.

The FMOD Studio is installed as usual (“next”-“next”-…-“finish”). The same command running via RDP on the Jenkins machine produced the error 87. I can run it on my machine no problem.
The graphics card is Radeon HD 2600XT and the driver version is 15.200.1062.1004.
I never worked with Qt myself, but I think the GUI/GFX is somehow intialized even when not called directly from an app. Here is the stack of fmodstudiocl.exe:

The process dump was made when the “error 87” window appeared.
Looking at that stack I decided to try to change the graphics driver to “Standard VGA Graphics Adapter” and it worked! Mannually changed the driver to AMD again and it still works. So your advice to reinstall the driver worked, thanks!

No problem, happy to see you’ve resolved the issue!

1 Like