For some reason, SetParameter is not accepting my FMOD parameter as an argument. How do i fix this?

I’m trying to manipulate the value from the parameter in Fmod with a value from the project.

emitter is the StudioEventEmitter that i’m getting from the object inside Unity. And rpmFmod is the name of the parameter inside FMOD (it shows up correctly in the inspector).

SetParameter is asking for a FMOD.Studio.PARAMETER_ID, which i’m not sure what is exactly, it’s not accepting just the name as a string… I’m not sure where to look for help because i’m not finding any references to this on Google, and i’ve already made exactly the same thing on another project before, which worked flawlessly. I’m on the same version of Unity and of FMOD. This error message is weird.

I’m on FMOD 2.02, if it’s of any help.

Thanks a lot for any guidance!

I FIXED IT! It was actually the dumbest problem possible: i had the wrong version of the integration package inside Unity. Once i got the right one installed, the problem was solved.