No Sound in Packaged Build UE4.21

Build cant find files for package as FMOD initialises after the blueprints that require it.

[2019.12.16-16.17.59:204][  0]LogStreaming: Error: Couldn't find file for package /Game/FMOD/Events/AlienLMG requested by async loading code. NameToLoad: /Game/FMOD/Events/AlienLMG

[2019.12.16-16.17.59:204][ 0]LogStreaming: Error: Found 1 dependent packages…
[2019.12.16-16.17.59:204][ 0]LogStreaming: Error: /Game/Code/Weapons/Parent/ParentWeapon
[2019.12.16-16.18.01:314][ 0]LogFMOD: FFMODStudioModule startup
[2019.12.16-16.18.01:314][ 0]LogFMOD: Lib path = ‘…/…/…/Engine/Plugins/FMODStudio/Binaries’
[2019.12.16-16.18.01:314][ 0]LogFMOD: FFMODStudioModule::LoadDll: Loading …/…/…/Engine/Plugins/FMODStudio/Binaries/Win64/fmodL.dll
[2019.12.16-16.18.01:316][ 0]LogFMOD: FFMODStudioModule::LoadDll: Loading …/…/…/Engine/Plugins/FMODStudio/Binaries/Win64/fmodstudioL.dll
[2019.12.16-16.18.01:369][ 0]LogFMOD: Loading strings bank: …/…/…/SuperTroopers/Content/FMOD/Desktop/
[2019.12.16-16.18.01:371][ 0]LogFMOD: Constructing asset: /Game/FMOD/Banks/Gunshots
[2019.12.16-16.18.01:371][ 0]LogFMOD: Constructing asset: /Game/FMOD/Events/AlienLMG
[2019.12.16-16.18.01:371][ 0]LogFMOD: Constructing asset: /Game/FMOD/Events/MilitaryLMG
[2019.12.16-16.18.01:371][ 0]LogFMOD: Skipping asset: bank:/Master.strings
[2019.12.16-16.18.01:371][ 0]LogFMOD: Skipping asset: bus:/
[2019.12.16-16.18.01:371][ 0]LogFMOD: Constructing asset: /Game/FMOD/Events/MilitarySMG
[2019.12.16-16.18.01:371][ 0]LogFMOD: Constructing asset: /Game/FMOD/Banks/Master
[2019.12.16-16.18.01:371][ 0]LogFMOD: Constructing asset: /Game/FMOD/Buses/Reverb
[2019.12.16-16.18.01:383][ 0]LogFMOD: Creating runtime Studio System
[2019.12.16-16.18.01:389][ 0]LogFMOD: Default sample rate = 48000
[2019.12.16-16.18.01:389][ 0]LogFMOD: System sample rate = 48000
[2019.12.16-16.18.01:389][ 0]LogFMOD: Matching system sample rate 48000
[2019.12.16-16.18.01:430][ 0]LogFMOD: Loading Banks
[2019.12.16-16.18.01:430][ 0]LogFMOD: Loading bank: …/…/…/SuperTroopers/Content/FMOD/Desktop/

FMOD is fully validated and working in engine.

  • Tried to reparent objects with FMOD events on to an empty actor with “IFMODStudioModule::Get();” implemented in Construction script to no avail and also tried to make a blueprint callable function that I put in the blueprint construction scripts of the objects in question but this didnt get rid of the fail to load error.

  • Have tried Disabling the Event Driven loader this removed the error however creates other crashes elsewhere in the project and doesnt allow me to actually get into the game to test the sound due to these crashes

  • Have tried setting the cookedonly module loading phase to “PreEarlyLoadingScreen” from “PreLoadingScreen” This crashes package instantly upon play

  • Have tried with ASYNC loading on or off absolutely no difference

  • Seemingly have exhausted all of the information online about this subject

If anyone has any information or can provide assistance it would be greatly appreciated.



Seemingly If instead of this:

I do this:


Then the game will package, this is slightly annoying however I can work with it until I have to set Bus volumes like this:


Knowing what the fix for individual events is I cannot seem to fathom how I would implement a similar fix for busses. If anyone could help it would be greatly appreciated as Im now days into this problem and its absolutely ridiculous.



What versions of FMOD and UE4 are you using?

UE4.21 & FMOD 2.00.06 both FMOD plugin and FMOD standalone are the same 2.00.06 version, does my problem and findings make sense to you or do you require more information?

Have you tried adding “IFMODStudioModule::Get();” to the constructor of the /Game/Code/Weapons/Parent/ParentWeapon? That appears to be the class that is loading before the FMOD plugin.

Please read my first post, Ive tried this already! The class in question is a Blueprint not inherited from any custom C++, I tried to write a C++ exposed Blueprint node that featured the “IFMODStudioModule::Get();” line and put that into the constructor of the blueprint but it seemingly made no difference.

Are you able to provide a sample project that reproduces the issue at all?