Oculus spatializer in FMOD


This might be the wrong forum to ask for support on this - but I’m having trouble with the Oculus spatializer inside of FMOD.

What I’ve noticed is that the Oculus spatializer has a very steep ramp in volume when you reach a certain distance. It’s around a +10dB change. There aren’t any options I can find to adjust this and it doesn’t provide any scale selection (unlike the FMOD spatializer). The only options are ‘Attenuation - ON or OFF’, radius, and a min & max distance 0.00 to 10k. The ramp is just very sudden. Their documentation says:

“Set to On to enable the internal distance attenuation model. If attenuation is disabled, you can create a custom attenuation curve using a volume automation on a distance parameter.”

Does this mean I have to make a curve in volume automation with an FMOD distance parameter myself?

As you have guessed, the Oculus Spatializer is a plug-in maintained by Oculus, so we at Firelight Technologies are unable to make changes to how it works.

I believe your interpretation of the Oculus Spatializer documentation is correct: Turning off the effect’s built-in distance attenuation will mean that the spatializer no longer attenuates or boosts the signal volume based on distance, forcing you to rely on custom attention curves.

If you want to re-use a custom attenuation curve and spatializing effect in multiple events, we reccomend automating the volume of a gain effect, and placing both the gain effect and the spatializing effect in the same preset effect chain.

Hi Joseph,

Thank you for your response - really appreciate the assistance considering it is another company’s plug-in.

I will give this a try - thanks for the suggestion.