Three EQ with all 0 gains still affects the sound

I thought, just like the FMOD_DSP_TYPE_PARAMEQ
and FMOD_DSP_TYPE_MULTIBAND_EQ, FMOD_DSP_TYPE_THREE_EQ would also skip audio processing when all gain values are 0.

Based on that theory, I came up with an equation for my dynamic sounds and applied the resulting values to the gains of Three EQs at runtime.
But the result wasn’t what I expected.
I didn’t know what was wrong until I tried with all zero gains.

Sounds needed to gradually and naturally get stronger or weaker depending on the situations, but they were already weak with the default/starting values of 0s.
I spent hours checking my code, but nothing was wrong.
So I finally installed FMOD Studio and tested Three EQ there.
The result?
I noticed the same issue with it!

Even though all gains were 0, my sound got noticeably weird when X-Low and Y-High were too close, or Y-High was lower than X-Low.
I also tried other X-Slope options, but those didn’t make any difference.

Is this normal behavior?

Currently, all my equations became useless :frowning:

I also note the weird behavior of the 3-EQ.
Perhaps could you rather use the Multiband EQ, which from what I understand is more recent and better designed. You could mimic what you had with 3-EQ by doing:
A : lowshelf
B : peaking (with a low Q)
C : highshelf
(or maybe peaking for all 3, haven’t tested)
When A-B-C gains are at 0, moving frequencies doesn’t seem to have any weird artifact, unlike 3-EQ.

1 Like

Thanks for telling me that I’m not the only one having the issue!

As for the Multiband EQ, I also know that it works well if you read the first line again. :slight_smile:
I like the Multiband EQ but there’s a time when the Three EQ is needed.
One example is this.

Thanks for the bug report. So far I’ve been able to confirm that the 3-EQ effect is definitely exhibiting some odd behavior when using a 12 dB crossover slope. I’ve yet to test whether other slopes also exhibit this issue, but I suspect that they will.

Accordingly, I’m adding this issue to our bug tracker.

Unfortunately, there is no easy workaround for this issue.

1 Like

Oh, that’s both good and bad news.
Good that it’s not intentional behavior, and bad that there’s no workaround right now.
Hope that will be fixed soon.
Thanks for the confirmation!

I have same issue with all crossover types. It sounds like phase problem.

1 Like

Thanks for the report. I’ve added you to the list of people who’ve reported this bug.

1 Like