UE4 not showing banks? (Mac)

#1

Hi all, I’m currently using UE4.21.2 with FMOD 1.10.12. I have installed everything in what appears to be the correct locations, and the fmod plugin is working fine within UE4. Unfortunately my banks aren’t visible in UE4’s content browser, despite showing up fine if I look at them in the folder itself.

I’ve tried validating FMOD in UE4 and this either shows nothing wrong, or sometimes comes up with ‘failed to load banks’, however I can’t find any reason why this would be the case, and google has been relatively unhelpful, so I was wondering if anyone here could help?

0 Likes

#2

Do the banks not appear in ‘Content/FMOD/Banks’ in the content browser?

The integration creates in-memory uassets for them as any other file type won’t shop up in the content browser.

Occasionally it may say that it ‘failed to load banks’, this is normally caused by the banks trying to be loaded while they are still being built by Studio. If you are unable to audition any events or play any event in editor then there may be a deeper issue.

0 Likes

#5

Hi there Cameron. I have the same issue. .bank files aren’t showing up in the content folder.
Manual ‘Reload Banks’ doesn’t affect on anything either.
FMOD version 2.0.0 E.A. - Windows 10.
UE4 versions 4.21 and 4.22 have same issue.

I didn’t had same problem with older versions. I forgot to backup my .fspro file now I can’t go back to older versions. :frowning:

0 Likes

#6

Are you getting any errors or warnings in the log?

The actual bank files will not appear in the content window as UE4 does not show all files on disk, only their .asset files. The integration should be creating these for the banks, although in memory and not on disk, under ‘Content/FMOD/Banks’.

0 Likes

#7

I know the .bank files should be shown as .usasset files. But I have nothing in my “/Content/FMOD/Desktop” folder in Content Browser. FMOD is creating .bank files but UnrealEngine doesn’t seem like creating .uasset files in the memory.
Take a look at the pics:


system

These are the output lines about FMOD

LogFMOD: FFMODStudioModule startup
LogFMOD:  Lib path = '../../../Engine/Plugins/FMODStudio/Binaries'
LogFMOD: FFMODStudioModule::LoadDll: Loading ../../../Engine/Plugins/FMODStudio/Binaries/Win64/fmodL.dll
LogFMOD: FFMODStudioModule::LoadDll: Loading ../../../Engine/Plugins/FMODStudio/Binaries/Win64/fmodstudioL.dll
LogFMOD: Default sample rate = 48000
LogFMOD: System sample rate = 192000
LogFMOD: Warning: e:\jk\workspace\2.0_UE4.22_Win64\core_api\platforms\win\src\fmod_output_wasapi.cpp(347) - IAudioClient::Initialize returned AUDCLNT_E_UNSUPPORTED_FORMAT, attempting stereo workaround.
LogFMOD: Warning: e:\jk\workspace\2.0_UE4.22_Win64\core_api\src\fmod_systemi.cpp(2802) - Output requires a sample rate of 192000Hz, resampling will occur.
LogFMOD: Default sample rate = 48000
LogFMOD: System sample rate = 192000
LogFMOD: Warning: e:\jk\workspace\2.0_UE4.22_Win64\core_api\platforms\win\src\fmod_output_wasapi.cpp(347) - IAudioClient::Initialize returned AUDCLNT_E_UNSUPPORTED_FORMAT, attempting stereo workaround.
LogFMOD: Warning: e:\jk\workspace\2.0_UE4.22_Win64\core_api\src\fmod_systemi.cpp(2802) - Output requires a sample rate of 192000Hz, resampling will occur.
0 Likes

#8

It looks like you have changed the name of the Master Bank, this will also need to be changed in the FMOD plugin settings menu.

As for the warning about ‘IAudioClient’, we have only heard of this occurring when using a virtual surround sound implementation (eg. Alienware audio drivers).

0 Likes

#9

I didn’t change directories. My project was working fine with v1.10.12. I upgraded project to 2.0.0 Early Access. And updated Engine version to 4.22 with updated plugins. Maybe a problem occured while opening v1.10.12 project with 2.0.0 E.A. version. I don’t know. :confused:

Ads%C4%B1z2

0 Likes

#10

Not the directory, but the actual Master Bank name. In Studio you have named it “MasterBank” but in the settings of the FMOD Integration it is looking for “Master”.


If you change this to be the same as in Studio, “MasterBank”, I am confident it will work (the editor may need to be reloaded).

0 Likes