Web app FMOD studio API examples give error... what am I missing?

Hi All, I found the Reference API with the Javascript tab here: https://www.fmod.com/docs/2.02/api/studio-api-common.html .
Once I figured out how to download the Studio API here:

I found the examples:

I popped the examples folder onto a webserver and tried to run them. The references to /public failed so I changed them to ./public sine the examples folder is not the web root.
When I run them now, they find the assets in ./public, but all give this error:

Creating FMOD System object

load_banks.js:111 grabbing system object from temporary and storing it

load_banks.js:123 set DSP Buffer size.

load_banks.js:135 initialize FMOD

fmodstudio.js:9 Uncaught TypeError: Cannot read properties of undefined (reading ‘addModule’)
at Array.ASM_CONSTS (fmodstudio.js:9:15958)
at _emscripten_asm_const_i (fmodstudio.js:9:23767)
at bSe (fmodstudio.js:14:60003)
at Fee (fmodstudio.js:19:73192)
at YLe (fmodstudio.js:16:69243)
at qid (fmodstudio.js:49:68886)
at $Qd (fmodstudio.js:25:7708)
at _Qd (fmodstudio.js:25:7488)
at Mdf (fmodstudio.js:23:597)
at tnf (fmodstudio.js:13:3984)

Is there another module I’m missing ?
Many thanks!

OK I found the issue. This gave me a clue:

Turns out FMOD requires HTTPS. Once I installed certbot and the letsencrypt cert on my web server everything works!

Many thanks for reading.