4.23 Integration Physics / Compile issues

I am currently investigating a strange terrain collision issue affecting a blueprint-only project. I have posted details on that issue on the UE4 answerhub here but I believe the issue can be tracked back to the FMOD integration.

I decided to create a fresh project (First Person BP) and add the FMOD plugin. I did not add any FMOD banks or build an FMOD project at all; just created an empty FMOD folder in the Content directory. I Ran the normal initialisation (Help > FMOD Validation), and then tried to compile the project to a standalone build, and I get this error:


Assertion failed: Local1.IsValid() && !Local1.ContainsNaN() [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/PhysicsEngine/ConstraintInstance.cpp] [Line: 359]

Once I disable the FMOD plugin, it compiles just fine.

Going back to my original project issue of strange terrain collision (again, see this post for more details on that), I made a copy of my original project, removed the FMOD plugin and all references to it, and the terrain bug goes away.

For some reason the 4.23 integration is interfering with UE4’s physics / collision system.

I am using UE4 4.23 and FMOD 2.00.05, and VS 2019

1 Like

Found the cause of the problem. The FMOD Plugin does not compile correctly under VS2019, despite UE4.23 supporting VS2019 as a compiler.

I switched to VS2017 and I could compile just fine.

1 Like

God, I’ve been two days butting heads with my project, had this exact issue. The thing is that I recently had some crashes related to a physics asset and had also added something using physics constraints, so I was crazy trying to figure out what the hell was wrong with those.

The only reason I found this post was that I was also having some weird warnings on UE4’s output log related to FMOD and decided to take a look here.

Thank you very much.

Are you able to share your steps for reproducing the issue?
What exactly was causing the conflict?

Building a project (i.e packaging for distribution, or running standalone) using VS2019 causes the problem. For me it happened on both UE 4.22 and 4.23, and on any of the 2.x branches of the UE4 integration.

I was able to build a basic project without any issues, do you need to add anything to the game for it to fail? Something in particular to do with terrain or physics?