Accuracy of Timeline Position

Hi, another dev here trying to build a rythm game :smiley:

I did notice that the timeline postion integer updates every 23 / 24 milliseconds. Is that adjustable for more accuracy?

My test is based on pure blueprints and an uncapped framerate. UE 4.22


I’m also trying to get the input times for the unreal engine independent from framerates, so I can test input times as consistent as possible. I was looking into learning c++ and asynchronous tasks for that, but couldn’t figure out a way till now.

Thx for the attention.


Solution addition: DSP Buffer Size (eg. 512) and DSP Buffer Count (eg. 2) were set to default values when I packaged the game because I used the plugin version 2.0001. 2.0002 solved this issue for me. And Don’t forget to set the Studio Update Periode (eg. 10ms)

The timeline position value is limited to the FMOD update time. This can be modified in the FMOD UE4 Settings Studio Update Period, which has a default value of 20(ms).

Hi Cameron,

thx for the replay. I still get the 23/24 ms update stepping when I print out the Timeline Position after changing the “Studio Update Period” in the Plugin Settings to 10ms (a notification popped up that the fmod Bank updated). I got the same from a packed game (developer build).

Apologies, on Windows you will also need to drop the DSP Buffer Length to 512, otherwise will only update Studio as fast as the Mixer is updated (20ms).

hi and sorry for the late reply,
but it still is on 23/24 ms steps. Could there be another more basic issue with drivers or something that could overwrite the update time?

I add my plugin stettings here, just in case something is wrong there.

What sample rate are you using in the Studio Project?
The 512 block is ~12ms @48KHz, but ~24ms @24KHz.

1 Like

hi again,
I was able to change it in editor, but not on a packaged project:

I was able to get the update time down to 5/10ms by setting the Sample rate in the Plugin settings to 192000 Hz. But I had to disable the “match hardware sample rate”. If this option is activated, even though I set my system sample rate to 192 kHz it seems to get capped to 48 kHz (based on the update time that was 21/22ms at that sample rate).

But with the settings that get me down to 5/10 ms in editor, On a packed exe it was up at 21/22 ms again, I also tested this on another System. Btw. I’m testing this with an empty scene at 1000fps - 1ms.

Setting the “DSP Buffer Length” had no effect. Its the same with various “File Buffer Size” and other values. Only the Smaple Rate seems to have an influence.

Sorry I should have mentioned this before, when you set the DSP Buffer size you will also need to set the DSP Buffer Count (Eg. 4). We could improve this so that you don’t need to set both, but at the moment you do, otherwise the buffer size alone will not be set.

1 Like

ok, when I set the DSP Buffer to 128 and the DSP Buffer Count to 2 I get varying values from 19 ms to 3 ms. That wouldn’t be too bad, if I was able to get that in a packed exe. Do I need to set a path to the plugin settings somehow when I package, just like the Fmod bank needs to be set as “Additional Non-Asset Directories To Package” in the Projekt settings?

No, these are built into the config files that the FMOD Integration uses at runtime.

Either the configurations are not built into the packaged project or the plugin is not using them, bacause I still get 23/24 ms as a result.

I guess it’s not that easy to view the config or even modify it afterwards, since there are only binaries and a *.pak file in the end.

I’m not sure why it wouldn’t be working, I can get it working in tests that I run here.

You could try deleting the Intermediate, Build and Saved folders, this will clean out any previously saved information for a build.

Ok, the plugin version 2.0001 was causing the packaged settings to be default. I did multiple tests with new projects and turns out 2.0002 does not have this problem on my machine.

thx for the patience X]