Android The getRecordDriverInfo method callback is 0. (Android)


(yourks) #1

In the record example, the getRecordNumDrivers method always returns numDrivers as 0, and the solution. (Android)


(Cameron Baron) #2

Some functionality inside of FMOD will require you set relevant permissions in your AndroidManifest.xml file.

  • Recording - to make use of the System::recordStart API use android.permission.RECORD_AUDIO.

Also the Audio Track output mode currently does not support recording, please use the OpenSL output mode for this.

https://fmod.com/resources/documentation-api?page=content/generated/platform_android/basics.html#/


(yourks) #3

I have configured the permissions required for the record example, but the number of test microphone devices is still 0.


(yourks) #4

record.cpp


(yourks) #5

System ->setOutput(FMOD_OUTPUTTYPE_OPENSL) has been set.


(Cameron Baron) #6

Make sure system->setOutput is called before system->init otherwise it will not do anything. You can confirm that it has worked by calling system->getOutput.


(yourks) #7

Thank you very much for your help! The problem has been solved!