Attenuation Setting for notify sound Occlusion


(Howu) #1

Hi,

I’m trying to make anim notify sounds be affected by occlusion settings.

I opened AnimNotify_FMODPlayEvent (concluded in fmod studio plugin content),
And I added a node - ‘Set Attenuation Settings’ - between Play Event Attached and Return Node on the Function ‘Received Notify’.

It Works In Game. Every events triggered on FMOD notifies have occlusion effect.

However, a fatal problem is occured.

At animation preview, Engine trying to play an FMODNotify, And Unreal Editor shut down.

I just want to 'do not shut down at the animation preview,
AND affect events triggered at notify my attenuation setting for occlusion - Just in game.

How can I fix it?

enter image description here
enter image description here


(Scott Rosenkrantz) #2

Hey how did you get the target node from Set Attenuation to attach to the return value in Play Event Attached? For me (using 4.11.2 and Fmod 1.08.02), it says AudioComponentReference is not compatible with FMODAudioComponentReference.


(Geoff Carlton) #3

Be careful not to mix up the inbuilt AudioComponent to the FMODAudioComponent, they are two different things!


(Howu) #4

Hi Scott,
You should use Class/FMODAudio Component/ Set Attenuation Settings, DO NOT use class/Audio Component/ Set Attenuation Settings.


(Scott Rosenkrantz) #5

Hey Howu, where do you find this? It’s not in my list of nodes for FMOD. Are you on 4.12?


(Howu) #6

Scott, Uncheck ‘Context Sensitivity’ and type “FMOD Set Atte~~”, or unfold directory ‘class’, ‘FMOD Audio Component’


(Scott Rosenkrantz) #7

Ok turns out I was using an older fmod/ue4 integration than the one that contains the FMOD Set Atte~~ nodes. Downloaded the 010804 Integration and they’re there now. Cheers!


(Geoff Carlton) #8

I set up something similar and I don’t see a crash at this end. Could you create a small UE4 repro project and send it to support@fmod.com?


(Howu) #9

Thanks, Geoff Carlton.

I’ll send you an email with some essential files for this test.

And, I’ve just found a hint.
Animation preview shut down when the FMOD Notify use bone name.
If bone name parameter is empty, this error doesn’t occur.