Attenuation on Character, Spatialization on the Camera -- UE5.1 - Fmod Studio 2.02.11

I’m trying to use the “Set Audio Listener Attenuation Override” node. It’s being called on my player characters blueprint on begin play. However nothing I set seems to have any effect. I’ve even tried setting the location to far far away just to see if anything was happening at all. Breakpoints hit though.

Trying the “Set Audio Listener Override” node in the same place works, but I don’t want to have spatialization on the character, and I don’t want to update things on tick to correct the rotation.

Has anyone found a way to implement this successfully?




Could you elaborate on the behavior that you are looking for not provided by Set Audio Listner Override?

I created a test, of a 3d emitter with a small attenuation sphere and the desired effect would be that if I stand next to it and pan the camera, the volume would stay the same (but the panning would change based on the camera). However the attenuation seems to stay attached to the camera and you can hear the volume go from 0 to 100 as the camera pans around.

I realize this may be more of an Unreal issue, but I thought maybe someone had come across the same problem here.


Thanks for the explanation.
Could you give the following blueprint a try and let me know if this is the behavior you are looking for:

Hope this helps!

1 Like

Thanks Connor, I always appreciate your help. At the moment my programmer has implemented a solution in C++, but for my own sanity sake I will test this method as soon as I’m able.


1 Like

Hello Connor, I’m trying to find a solution to the problem brought up in this thread, so I tried using the method you shared but I had no success.
I’m using 4.27 and the latest version of fmod, I don’t have much experience so I might be doing something wrong.

Does the audio listener override work with fmod or is it only for unreal native listener?
If it doesn’t, would changing the listener settings need to be done in C++?

Thanks in advance.


The FMOD listener overrides the UE native one so using the listener override node should be setting the position of the FMOD listener.

What is the issue you are experiencing?

Hi Connor, thanks for your reply.

So I tried adding that code and then feeding the character location to the attenuation override and then I would use the camera rotation for the listener override. But it was not behaving as intended.

I found these 2 solutions to the problem:

Maybe there is a simpler way to do it, but I found this to work pretty well. If there is an easier way I would love to know.

Thanks again. Cheers

1 Like


I also used the Audio Listener Override Tutorial as a reference so that is a great solution.

If you have any more questions, please do not hesitate to ask!