BUG? Can't drag asset from bank, must restart

I apologize if this is the wrong place for this but:

Description: FMOD Studio tool gets in a broken state where the user cannot drag assets from the audio bin. A Studio restart fixes the problem.


  1. Open FMOD Studio and open a project
  2. Create a new event
  3. Create a multi-sound on the timeline
  4. Open the Assets bin
  5. Select multiple assets
  6. Attempt to drag them into the multi-sound “Drop sounds here” area

EXPECTED: multiple sounds end up in the area, OR, at least one sound ends up in the area, OR, can’t drag multiple sounds.

OBSERVED: nothing happens, and user can no-longer drag single sounds from assets bin either.

WORKAROUND: restart the Studio tool. dragging single sounds now works (for a while.)

NOTE: I think there is more than one way to trigger this buggy state, this is the one I can reproduce most easily.

So, am I doing something dumb? corrupt project file? is there a way to fix this without restarting studio? I’m pretty new to Studio, but, this seems really broken.

Thanks for reporting this issue. Unfortunately, I haven’t yet been able to reproduce the behaviour you describe. It’s possible that it’s only present in certain versions of FMOD Studio, or that it only afflicts certain projects. Could you please let us know which version of FMOD Studio you’re using? And are you able to reproduce this issue with our examples project?

Hm. I feel like I haven’t fully isolated it, for sure :slight_smile:

I am using FMOD Studio 1.08.09 on Windows 10. Yes, I see the same behavior with Examples.fspro.

The examples project opens up. When I create a new event, a new multi-sound, and try to drag multiple assets in at the same time, I do see the same problem. The asset list looks disabled when I attempt this, but then goes back to normal when I click back in.

I found even easier steps, using the event bin.

STR with Exampls.fspro:

  1. Open fmod sturdio 1.08.09 on Win10.
  2. right click “weapons” folder and select Full Auto Loop event.
  3. shift-click to select Single-Shot
  4. attempt to drag both events somewhere.

should be able to drag multiple items.

The drag looks like it’s going to work for a split second, and then stops. It is now no-longer possible to drag assets or events, even single ones.

Restart FMOD studio. never drag multiple items, just single items.

Repro Rate:
3/3 plus 5/5 related tests with dragging multiple items from Assets Bin.

Hope that helps. I’m able to get my work done but this threw me for a loop at first.

Hi Nate,

I haven’t been able to reproduce the bug as yet. Wondering if it is possible you to reproduce the issue using the steps you provided, and send us a log via the
Help->contact support@fmod.com menu option instead?

I sent logs. Thanks for trying, maybe it’s something with my setup. I tried disabling my clipboard manager, and I tried rebooting but problem still 2/2 repro for me.

It seems that Synergy (KVM software) was interfering with Drag and Drop. Killing the synergy process resolved the issue for me.

Hi Nate,

Thanks for the update. Glad to hear you have narrowed down the issue to Synergy interfering with Drag and Drop and terminating the process fixes your issue.