Build preferences project platforms list is blank

I’ve just upgraded from 1.05 to 1.08 and am not able to build banks again. It tells me to set up the project platforms in the build preferences, but I can’t because it’s blank. Why is it blank?

Do you have any platforms setup/assigned in the Banks tab of the Event Editor window?

Thanks for the reply. I don’t see anywhere to assign platforms in the banks tab of the event editor window. Am I looking at the wrong thing here?

As of 1.08.00, the banks tab of the event editor window is no longer used to set up platforms. You do it in the Build tab of the Preferences window - We’ll post an answer explaining how shortly.


Is this a brand new project or an existing project? Studio uses the building settings of the MasterBank to determine project target platforms post migration. Were there any build settings on the MasterBank in the project before the migration?

1 Like

The short answer to “why is it blank” is that your project doesn’t have any target platforms yet. To add a target platform to your project, right-click on the blank space to open the context menu, and select ‘Add Platform.’ (We should probably display text that says “Right-click to add new platforms” when there’s no target platforms in the project. I’ll add that to our feature/improvement tracker.)

The long answer is that 1.08.00 handles platforms differently to previous versions in a number of ways.

One of the really big differences is that platforms aren’t a property of banks any more. (Platforms being a property of banks was an artifact of the changes made when going from Designer to Studio. It made sense at the time, but that time has since ended.) Instead, target platforms are something you set up for the project as a whole, in the Build tab of the Preferences window.

A second really big difference is that compression and encoding settings are no longer something you need to set per platform, per bank. Or rather, they are something you can set per platform, but the platform’s setting just acts as a default; You can also set the encoding format of individual sound files in the assets browser, and an audio file with a custom encoding format will use that format instead of the platform default. This means that a single bank can now contain audio files encoded in a variety of different ways.

Finally, you can now specify a different speaker mode for each platform.

As you can see, we’ve made a lot of changes. Let us know if you have an questions!


Thanks, right clicking shows the option to add the platform. Yes, a note in the GUI there saying to do that would have saved me a lot of time and prevented the question from being asked. It was not at all obvious to me, and it only works if you right click the list box on the left side. Or maybe in the space where it says “select a platform to view its settings” you could put a button to add platform. Something somewhere anyway would have been helpful.

Anyway, thanks for the answer, Joseph. I’ll give this another try today and see how things go. The new integration with Unity looks nice (I’ve used legacy until now, was not even aware of an update), much easier to work with than the old system by the looks of it. Being able to just drag/drop a sound into the scene is lovely. :slight_smile:

Just switched over to integration 2 and it was pretty simple and straightforward. Didn’t require much. So far I like the new integration a lot more. It really simplify things. Good job, guys. :slight_smile:

1 Like