Can't build project in Unity - Fmod Studio Integrated


I have a project in Unity which has the Fmod Studio plug-in integrated, version 1.05.09.

I’m trying to build the project for Windows/Mac OS/Linux but the console shows me the following error:

Assets/Plugins/FMOD/FMOD_StudioEventEmitter.cs(183,20): error CS0103: The name `FMODEditorExtension’ does not exist in the current context

Any ideas on what’s happening?

I’m using Unity Free, by the way, I’m not sure if that has anything to do with it. I can run the game and listen to Fmod events just fine on the editor.


I just got the same problem after importing 1.07.01 to an empty project with Unity 5.2.2f1. Is this a regression?

Me too - just upgraded Unity to 5.2.2f1 using FMOD 1.06.10, Unity worked but project wouldn’t build, same error.

Upgraded FMOD to 1.07.01, now the FMOD menu is gone from the Unity editor and I can’t run my project. Getting the following error:

“Assets/Plugins/FMOD/FMOD_StudioSystem.cs(161,51): error CS0246: The type or namespace name `FMODAsset’ could not be found. Are you missing a using directive or an assembly reference?”

Time to downgrade Unity again, I’m guessing?

For anybody using Unity Integration 1.05.09 like the original question please upgrade to 1.05.10 or later to fix the issue.

For people who have just upgraded to Unity 5.2.2 and found this post, please see