FMOD Does not exist in this current context


I’m just getting started with using FMOD in Unity. I get a ton of errors in my VS Code and I don’t know why because I haven’t even done anything except import the latest 2.01.05 Unity package downloaded from the website. I put an event emitter in my scene to test if it still works, and oddly it does work. I tried building to see if my problem was similar to some others around the forum, and my build failed for Windows. I haven’t seen anyone report having over 400 errors in their code just off of the package they imported though. Anyone have an idea how to fix this? Else I will have to just scrap the usage of FMOD for my team’s project even though it’s functionality is ideal for it.

Thank you,

Hey, so I actually figured it out on my own. I believe it has to do with VS Code being buggy. When I switched to using my VS Community 2019 it worked nicely and I believe the problem building was from an separate source from FMOD. All in all, when using FMOD use VS Community 2019 as your main code editor if you don’t already.