DllNotFoundException: fmodstudio on Mac

I build a project using Windows for Mac
When I tested in Windows Unity with Mac selected as target platform and everything worked fine without error, but when I actually build it and run it on a Mac this error appears

This same thing happens to me. Here’s a screenshot of the log that shows it:

We recently updated Unity to 2019.4.14f1 (from 2019.2.21f1), not sure if that would have anything to do with it. We’re on FMOD version 2.01.05 (the latest Unity verified version). Maybe I’ll try updating to 2.01.06 next?

This is on Mac OS 11.0.1 (Big Sur)

If you make an empty Unity project and just install FMOD into it do you get this problem?
If not could you share the full player log?

We’ve not been able to reproduce this, I’m using Unity 2019.4.15f1 on 11.0.1 (Big Sur) with FMOD 2.01.05 from the Unity store.

We met the same issue on macOS Big Sur, using Unity 2019.4.14f1

Is there any way to make that kind of sample project and play an actual sound? Without making sounds in FMOD studio (which isn’t something I know how to do… I just handle the Unity code side of things).

I ask because, according to the logs I shared, the error only reveals itself when I try to play a sound. So I suspect in a sample project the error won’t happen until I attempt to play a valid sound.

You will need sounds made in FMOD Studio to get started.
The simplest thing to do would be to open our examples project in Studio and build the banks.
Then connect Unity to the Studio project and setup an emitter.

The basics are described in our user guide.

same issue on macOS using Unity 2020.1.15f1

@erdem224 Is this a new project? Can you test with an empty Unity project playing one of our examples?

For everyone with this issue, make sure you’ve deleted fmodstudioL.bundle before updating as per the update instructions.

We’re keen to identify the cause of this but after many attempts have been unable to reproduce it, if anyone can share clear steps we can repeat here and cause this we’d be most appreciative.

Finally had a chance to try fully reimporting the plugin, and that worked! So who knows… glad it’s working now though!

I’m also facing the same issue with Unity 2019.4.10f1 using FMOD 2.01.05. Is the solution here to update FMOD?

Here’s a pastebin with the errors running on Mac, any help would be greatly appreciated!

Do you have this problem if you integrate FMOD into a fresh empty Unity project?

I haven’t tested that, but I completely removed FMOD from the project, and then reimported it which seems to have worked. That being said, when I clone from github, it breaks again.

Here’s my gitignore. This is the default one Github allows you to add to a project.

This issue could be related to one we are tracking in another thread caused by line endings in the Info.plist. Please take a look at this other thread and try the command line I suggest on your broken project.

same issue on Unity 2021.3

DllNotFoundException: fmodstudioL assembly: type: member:(null)
FMOD.Factory.System_Create (FMOD.System& system) (at Assets/ThirdPlugins/FMOD/src/Runtime/wrapper/fmod.cs:766)


Which version of FMOD are you using?

Can I get a screenshot of your FMOD Plugin within Unity exposing the mac platform:

Hi! We’re having the same problem here.
Unfortunately our project doesn’t run or build properly on Macs due to error:
DllNotFoundException: fmodstudioL assembly: type: member:(null)

The problem is present on Mac Big Sur 11.6.1 & Monterey 12.1
We use Unity 2021.3.4f1 and FMOD 2.02.07
We tried all those things but nothing helps:

  • an empty Unity project
  • upgrade to 2021 Unity LTS
  • changing line endings for Info.plist
  • reinstalling fmod plugin
  • modifying project permissions in macOS
  • changing import type for native Unity modules


Can I confirm the operating system you are using to make the builds?

We’re using this one to make builds:

Unfortunately, I am not able to reproduce the issue.

Are you getting the integration from the Unity package manager or are you downloading it from our site?

With the integration installed could I get a screenshot of your Assets -> Plugins -> FMOD -> platforms -> mac