DllNotFoundException: fmodstudio - license error or something else?

I am working with on a project using Unity Teams (their cloud service) and in the beginning of the project Fmod and Unity worked fine for me but since other team members integrated Fmod to be able to hear the sounds I keep getting this error:

DllNotFoundException: fmodstudio
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced, Boolean blocking) (at Assets/Graphics/Plugins/FMOD/Wrapper/fmod.cs:1629)
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced) (at Assets/Graphics/Plugins/FMOD/Wrapper/fmod.cs:1624)
FMODUnity.RuntimeUtils.EnforceLibraryOrder () (at Assets/Graphics/Plugins/FMOD/RuntimeUtils.cs:391)
FMODUnity.StudioListener.OnEnable () (at Assets/Graphics/Plugins/FMOD/StudioListener.cs:17)

This has resulted in them hearing the sounds, but not me. I looked around and saw that I might need Unity Pro to use it? But I don’t get why the sounds would work earlier and now only for other projectmembers then? Don’t know if it’s relevant but they are all using Windows, while I’m using Mac.

Unity Pro is only required when using Unity 4, because plugins were only available to Pro users.
It looks like you are missing the required libs. The standard FMOD Unity Integration comes with both Windows and Mac libs (and plenty of others). They should be located in:

Simply re-import the Integration and it will give you the option of importing anything you are missing.

Hello, I have a similar error:

DllNotFoundException: fmodstudioL
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced, System.Boolean blocking) (at Assets/Plugins/FMOD/src/Runtime/wrapper/fmod.cs:890)
FMODUnity.RuntimeUtils.EnforceLibraryOrder () (at Assets/Plugins/FMOD/src/Runtime/RuntimeUtils.cs:375)
FMODUnity.StudioListener.OnEnable () (at Assets/Plugins/FMOD/src/Runtime/StudioListener.cs:21)

To re-import I only need to download the integration package and in Unity import custom package or should I delete some elements?

Usually just reimporting without deleting anything else works fine. Please let me know if you are still getting the error after reimporting though.

Hi Jeff,

That solved the problem. However now I have the error CS0433 (The type EventInstance’ exists in both ‘FMODUnity, Version=, Culture=neutral, PublicKeyToken=null’ and ‘Assembly-CSharp-firstpass, Version=, Culture=neutral, PublicKeyToken=null’)

I think this may be related to duplicate files.

It does sound like it’s related to the pre-existing installation. What version of FMOD are you using? Perhaps try deleting the Assets/Plugins/FMOD directory and then reimport again.

Version 2.01.11. Done. It is solved.

Thank you very much