error code: 2 when submitting to perforce

I’m connected to my teams perforce server, whenever I build my project and try to commit it to the depot it gives me <Error: system.start failed (error code: 2).>

Any idea how to fix that? I’m on Mac OSX 10.10.5 and we are working with Unreal Engine 4.13

The same procedure works on a windows machine, so it might be a Mac issue.

Thanks for your help.


It looks like the operation has taken longer than we expected. In the script, we default to 10 seconds for any given Perforce operation. If it takes longer, we would bail and return the error you are seeing.

There are a few legit reasons why an operation could take longer than 10 seconds, for example an offsite perforce server or simply a large number of changes with huge files are submitted.

We are looking at ways to improve the handling of a bad connection. In the meantime, you would have to open the Studio app package and modify the script file. There should be a script in the scripts folder. You can look for the a line with timeout: 10000 and change that to timeout: 120000

1 Like

Thanks! I ran into the same issue. Changing the timeout in the script fixed it.