FMOD 2.02 package for Linux AArch64 Fail - UE 4.26

Hi, I’m building out a project for Linux(AArch64) but get error in link.

UATHelper: Packaging (Linux (AArch64)):   ld.lld: error: Plugins/FMODStudio/Binaries/Linux/arm\libfmodL.so:1: unknown directive: XSym
UATHelper: Packaging (Linux (AArch64)):   >>> XSym
UATHelper: Packaging (Linux (AArch64)):   >>> ^

I have modified the Build.cs to make it use the correct lib

else if (Target.Platform == UnrealTargetPlatform.LinuxAArch64)
 {
        libPath = System.IO.Path.Combine(LibRootDirectory, "Linux", "arm");
        linkExtension = ".so";
        dllExtension = ".so";
        libPrefix = "lib";
 }

I have not been able to reproduce this issue by cross-compiling a FMOD 2.02/UE4.26 project to AArch64 on Windows- are you cross-compiling or packaging natively?
One thing to check would be that FMOD is installed as an engine plugin and not a project plugin- the additional paltform steps for packaging linux has the specifics if you haven’t checked it already.

@jeff_fmod Thanks for your reply.
It still doesn’t work. Did I miss anything?
1.add in both the fmodstudio linux .zip and windows .zip on top of each other into the engine plugins directory. like D:\UnrealEngine\Engine\Plugins\FMODStudio
2.create a sample ue project : F:\Code\ThirdPerson
3.copy the lib directory D:\UnrealEngine\Engine\Plugins\FMODStudio\Binaries\Linux\arm to F:\Code\ThirdPerson\Binaries\LinuxAArch64

I’d like to add to this and mention that we’re also getting the same issue with 4.26/2.02 and cross-compiling to Linux. I’ve also copied binaries from the engine plugin folder to Project/Binaries/Linux

That appears to be the correct process in each of your cases. To help me reproduce the error, can you please tell me your full FMOD version, i.e 2.02.01? Can you also please confirm that you are building UE from source as opposed to installing from the Epic Games Launcher?

Hello,

We are also having the same issue. We also noticed that the .so files are tiny in the 2.02 builds (for all of them including early access) it looks like they are not valid libraries. The zip files are around 500kb when downloaded. But going back to 2.01, all the integration zip files are 12mb.

Looking at these .so files, it seems that they are symlink shortcuts instead of the actual binaries themselves.

We’re using Unreal Engine 4.26 and have had no issues until upgrading to 2.02. (Also doing Linux x64, not AArch64)

EDIT: We found some valid Linux binaries from downloading the FMOD Engine, and looking for the .so files in that, instead of the ones that come with the FMOD Integration plugin.

Apologies for the confusion, I have discussed this issue with the Dev team, and while we support Aarch64 via the API, we do not currently support it as a platform in the Unreal Integration.
Linux x64 is supported, but you do require a source build of the Unreal Engine for it to package correctly.
@Dec Thank you fo raising this issue, the .so files in the UE Integration are indeed symlinks, we will fix that up- in the meantime using the .so files in the FMOD Engine should be fine.

Installed Patch 1 on Linux today and I’m still getting the same error that was originally posted. No cross-compiling, just trying to build the engine from source with the plugin in the engine folder. Engine builds fine if I remove the plugin.

We have recently uploaded a new patch which has the correct libraries for x86_64, can you please try reinstalling the plugin and Linux platform extension from our website?

Using Unreal 4.27, compiled from source with the plugin in the engine folder, with FMOD 2.02.03 Patch 2 on Ubuntu 20.04 LTS. No compile issues.

Opening the editor gives this error:

Recompiled without it in the engine plugins folder and was able to open the editor.

Compiled everything with the plugin in the project plugins folder and it compiled successfully. Opened the editor and it opened successfully. Opened the project and it gives the same error above.

Is this a Code project or a Blueprint-only project? It sounds like a known issue that affects UE Plugins in Blueprint-only projects. The workaround is to create a C++ class in your project. Please let me know if this is already a Code project or already has some C++ somewhere and I’ll investigate further.

Code project.