FMOD Error 28 when trying to initialize system


#1

Hi guys, I am trying to do basic sound design using FMOD, but keep getting “The thread … has exited with code 28” when I try to compile. I checked the error flags and realized this is “FMOD_ERR_INTERNAL”, which when I looked up the meaning of it in the API, it says “An error occurred that wasn’t supposed to. Contact support.”. This error occurs immediately after I try to initialize the system, specifically after I compile these two line:
err = FMOD_System_Init(system, 10, FMOD_INIT_NORMAL, 0);
if (err != 0) exitOnError(err);
Any suggestions on what it could be, or where I could get some help on this?


#2

During compilation? Sounds like your compiler is broken. FMOD shouldn’t have anything to do with the compilation producing thread errors, or are you actually running the program via the debugger?

If so, you should use fmodstudioL and fmodL libraries, and look at the log file it produces, and see what the error is.
regards,


#3

I’m in the same boat as OP. I’m getting the same error and it’s driving me absolutely nuts. I’ve been searching around on the internet for an answer for about 3 hours now and I can’t seem to find a solution. I’m writing my program in C++ using Visual Studio 2017 and currently this is all that I’m doing before the error appears:

FMOD::Studio::System::create(&this->studioSystem);
this->studioSystem->initialize(256, FMOD_STUDIO_INIT_LIVEUPDATE, FMOD_INIT_PROFILE_ENABLE, 0);

That’s as far as I get before I run into the ‘Error 28’. I have also tried the following alternative:

this->studioSystem->initialize(256, FMOD_STUDIO_INIT_NORMAL, FMOD_INIT_NORMAL, 0);

However, this also does not work as it produces the same error. Another solution I tried was to just initialize a ‘System’ and ignore the ‘StudioSystem’. Furthermore, I even tried calling the following function right before I initialize:

this->system->setSoftwareFormat(48000, FMOD_SPEAKERMODE_STEREO, 2);

However, that didn’t work either as the same error remains.The following ‘[LOG]’ files are created as I run the program in debug mode:

[LOG] System::create : Header version = 1.10.10. Current version = 1.10.10.
[LOG] Manager::init : maxchannels = 256 studioflags = 00000001 flags 00010000 extradriverdata 0000000000000000.
[LOG] SystemI::init : Initialize version=11010 (98815), maxchannels=256, flags=0x00030000
[LOG] LiveUpdate::release :
[LOG] LiveUpdate::reset : Reset connection (reason Disconnected)

I am running Windows 10 and I have double checked that I have downloaded the FMOD windows 10 version. This being due to the fact that I accidentally downloaded the other version for windows and it gave me a whole bunch of linking errors. After I downloaded the win10 version they all disappeared, leaving me with this bug instead.

Any help would be greatly appreciated! <3

EDIT: Extra info that probably won’t help, but maybe…

  • 64-bit, Debug Mode
  • ‘Additional Dependencies’ Files: fmodL_X64.lib and fmodstudioL_X64.lib (no ‘L’ for release)
  • Couldn’t compile earlier because I was missing “VCRUNTIME140_APP.lib”, which I manually downloaded to solve the problem

#4

Can you confirm that the examples that come with FMOD in low level or studio api folders, run without this error?


#6

Hello again!

Sorry for the delay in regards to getting back to you, brett. I tried to run the example code but it didn’t work initially due to me having Visual Studio 2017 while the project was created using Visual Studio 2015. This required me to download some GB’s worth of compatibility/support so that the VS 2015 project could be run. I did this, however it still didn’t work. There were various errors, one of them having to do with the SDK version being incorrect or incompatible or something similar. I did also try and fix this with the help of various google searches but there didn’t seem to be a clear cut solution.

With all that being said, we have a DX12 project deadline coming up and so that’s taking priority. SadBois. As such, I’m going to be looking more into this problem in a couple of weeks. Worst case I’ll possibly (and also very sadly) be moving to another API that can provide sound-playing functionality if I can’t get FMOD to work. Hopefully someone else who’s had the same problem posts some suggestions or a solution when the time comes that I start working on this again. Thanks!


#7

Hi Brett,

I also tried running the example codes and am getting the same error. My machine specifics are the same as Oliver’s, and yes I am also running in the debug mode. I am going to try to redownload VS and the .NET framework and see if a complete system reset does the job.


#8

we have thousands of people running the api so there must be some odd configuration issue you both share. I would like to see a log output using the low level API, just to rule out the studio api , and if the low level API passes/works, then maybe with or without live update in case its some sort of networking error.


#9

[LOG] SystemI::init : Initialize version=11010 (98815), maxchannels=32, flags=0x00000000
The thread 0x2928 has exited with code 28 (0x1c).
The thread 0x12d4 has exited with code 28 (0x1c).
The thread 0x3f5c has exited with code 28 (0x1c).
The thread 0x2e5c has exited with code 28 (0x1c).
The program ‘[8220] FMOD Project.exe’ has exited with code 28 (0x1c).


#10

Is this the log you are looking for? This is the log output from my most recent compile


#11

Im not sure what all those threads are, but according to your log fmod’s threads havent event started up yet. I think the 28 = FMOD_ERR_INTERNAL is a coincidence and its just some devstudio crash that happens when the debugger is connecting or something.

Have you run out compiled examples outside of the development environment yet?


#12

I’ve finally got some time now during the weekend to try and fix this pain-in-the-ass of a problem. However, so far there’s been more or less zero progress. I’ve been trying various solutions; removing the Studio System and only using the System (still error 28), I’ve double checked include files and libs, still nothing…

A quick question: when installing FMOD (windows 10 version), does it have to be installed in the location that is initially specified in the windows folders on the C: drive? Could it be that because I instead chose to install FMOD directly into my project files that it isn’t working?

P.S. I know that it is extremely unlikely to be the fault of anyone posting here on this topic so I’m not trying to attack anyone personally, but HOLY @#*! is the “You-Can-Only-Post-Three-Times-Per-Topic” system absolute GARBAGE. On top of that, the fact that it takes 24 hours to delete a previous post is the equivalent of pouring the entire salt shaker into the wounds already inflicted by said garbage system. So with that being said, if anyone is wondering why I deleted one of the previous posts on my other account here on this topic, then it’s because I didn’t want to have to create another account just to continue discussing this problem… but here we are. :expressionless:


#13

Apologies about the forum, it looks like those settings are default discourse settings. I changed 3 times per topic to 10, it is to avoid flood spamming i assume, and deletes per minute is 3 per minute, not per day that I can see. I changed that to 10 as well.

As for your issue, I don’t think it is fmod related, there are no requirements on where you install.

As your post didn’t address my theory, i’ll have to repeat it

it [looks like] some devstudio crash that happens when the debugger is connecting or something.

Have you run out compiled examples outside of the development environment yet?

I think it is more to do with your visual studio installation at this point.