FMOD is crashing when I add a parameter


(Roman) #1

Hello,

I just started using FMOD and ran into some problem that stops me from using the app completely. Currently I’m running FMOD Studio 1.10.05 in macOS 10.13.4. Whenever I add a parameter to an event (I need to add distance, but any other yields similar result) FMOD either crashes or freezes forever. The same behavior with new and existing projects. When I open a project like FMOD_tute it’s running ok. The parameters within work perfectly. But adding one breaks everything apart.

Anyone has the same issue? Any workaround so far?


(リチャード清水) #2

Hi Roman,

Sorry to hear about your crashing.

Could you try uninstalling FMOD Studio and delete the folder ~/Library/Application Support/FMOD Studio. Reinstall FMOD Studio and see if the same issue occurs.

Thanks,
Richard


(Roman) #3

I tried reinstalling but no effect.

In addition I don’t have an “FMOD Studio” folder in ~/Library/Application Support/


(Roman) #4

Seems like something is wrong with my profile. I tried logging into macOS with another profile and run FMOD Studio: here it works perfectly.


(リチャード清水) #5

Thanks for the update, Roman.

Does your profile name contain any non-ASCII characters (anything other than A-Z)?

Thanks,
Richard


(Roman) #6

No, it’s only alphabetical.

I’d like to note that previously there were no problems.

I’ve figured out that if I log off and sing back in the issue vanishes for a while. I usually have my profile running continuously without loggin off for days. Thus maybe that’s some other programs or detacheble hardware that conflict FMOD. I just need to find out which one.

Luckily, there’s a temporary cure for me :slight_smile: I can log off and sing in in order to resolve this issue until it arises again.


(リチャード清水) #7

I see, thanks for letting us know. If you run into any more issues please don’t hesitate to ask.

Thanks,
Richard


(Francesco Del Pia) #8

I’ve got the same exact problem, and I’m also running FMOD Studio 1.10.05 on macOS 10.13.4. Deleting the FMOD Application Support folder and reinstalling FMOD didn’t solve the problem. Switching to another user - like ‘Guest’ - fixes the issue, but it’s not a viable solution for my workflow. My profile user name only contains alphabetical characters. I tried running FMOD in the Bootcamp partition with Windows 10 installed, and it works fine there. Is there anything else I can try in order to fix this issue?


(リチャード清水) #9

Hi Francesco,

Could you please check your Accessibility options in your macOS system settings and see if you have any accessibility settings in place? We have noticed your crash report and we believe it may be a narrator accessibility option that is causing a similar problem.

Thanks,
Richard


(Francesco Del Pia) #10

Hey Richard, thank you for your help! I was able to fix the issue. It turns out that what was causing FMOD to crash was a little piece of software I had installed called Karabiner, which I use to ‘fake’ numpad input from my laptop keyboard. By disabling its privacy authorizations under System Preferences > Security and Privacy > Accessibility > Privacy I solved the problem. Thank you so much for your help! :slight_smile:


(リチャード清水) #11

Hi Francesco,

Thank you for the heads up.

We’ve tested and found that Karabiner 10.21.0 and earlier does indeed cause this crash. There was a fix in 10.22.0 that resolves this issue. You can update Karabiner to the latest version and continue to use both Karabiner and FMOD fine on your Mac.

Thanks,
Richard


(Francesco Del Pia) #12

Great to know they fixed that bug in Karabiner. Thanks Richard! :slight_smile:


(Jorick Bronius) #13

I’ve been having the same problem with a tool called “DisableMonitor” or “Teleportd” in Accessibility. When turned off the problem was resolved. I didn’t test which of these was the culprit yet.


(リチャード清水) #14

Hi Jorick, Have you tried using the latest build of FMOD Studio (1.10.09)?