FMOD Panner on 2D event gets cancelled in master Bus

A picture is worth a thousand words, so:

I have added an FMOD Panner to my event master track, the “out” preview correctly shows sound only being played on the left channel according to the panner’s value, but on the master bus (and in my speaker) there is sound on both channels.
This event isn’t routed in any group whatsoever, and I’m all out of ideas to what I could be doing wrong. Any suggestion about how I could get this right?

Are you sure the event is routed to the master? Are there some effects on the master bus? Are you sure there’s only one instance of your event playing (there could be several instances with several parameter value)?

Hey Alcibiade, thanks for taking some time to help me :slight_smile:

  • It looks like it’s correctly routed into Master (“Route into master” is checked).
  • There are effects on the master bus (volume automation, reverb and multiband EQ), but I tried to disable them all with no change on the panning issue.
  • I think that’s the only instance playing, since I’m only triggering it from the Play button in FMOD Studio, not from an integration. My event has a weird structure though, with nested events, so I tried on a very simple event with only an instrument on a timeline, and the issue is still there.

Your questions may have allowed me to narrow the issue a bit more though, since when I select the Master bus in the Mixer and play my event, I can see that in the “In” preview, only one channel has sound, whereas in the “Out” preview, both channels have sound, even though there are only my disabled effects there, so I guess something weird happens in the middle of this.

It may be something that transforms the signal to mono at one point of the chain (after the event panner), maybe in the master bus effect chain, then the signal is re-split to stereo later. Even a by-passed effect keeps it downmixing settings.

1 Like

I… feel pretty dumb >_> Apparently, somehow I either forgot to try to bypass the Reverb effect, or I didn’t notice it fixed my issue, because… well it does ^^’ Thank you for your help that forced me to recheck what I thought I already did, the reverb effect is the culprit (the worst is, that seems retrospectively obvious…).

1 Like