FMOD_STUDIO_STOP_IMMEDIATE causes clicky noise

Using EventInstance::stop() with the FMOD_STUDIO_STOP_IMMEDIATE argument causes clicky noise on the event finishing. You can reproduce this issue inside FMOD Studio by repeatedly playing and stopping the event by ctrl-shift-space or via FMOD Studio API acting the same way. I’ve tested FMOD 2.02.06 and 2.02.08 with the “UI/Cancel” event from Studio examples.


If it is possible use the FMOD_STUDIO_STOP_ALLOWFADEOUT option instead to avoid clicking. If not then set the volume of the event instance to 0 using EventInstance::setVolume() just before you call stop(). This will hopefully help the clicking.