Fmod Studio SVN Integration

Hi there. I added SVN integration to my FMOD project successfully. In case this is important, this project was already using TortoiseSVN but only now I have used the integrated SVN Version Control feature.

So everything works as expected but is very slow. Saving takes more than a minute. Doing a commit can take 2-3 minutes.

I found other posts in the forum and this information:

But this is the weird thing. If I do the test the documentation suggests, I get a quick response, around a second but there is a short pause between the two files. But on the other hand Fmod Studio is still very slow.

Looking at the Repository Root, it is already using the IPv4 adress and not a domain name. I also asked IT and the tell me our SVN server uses IPv4 so I assume the IPv6 solution that appears in the documentation doesn’t apply to me.

So basically, all looks good already and follows the recommendations from the docs but fmod studio is still super slow. Anything else I can try?

Which version of FMOD Studio are you using and are you able to provide some logs? Open the project and perform a commit, then copy the latest log from %localappdata%\FMOD Studio\Logs. It might shed some insight into what could be going on in your situation.

Thanks Richard. We use 2.02.03

I did a commit and looked at the log file. At first glance, I don’t see anything related to SVN or version control. I don’t see anything that looks like an error either. I just sent the log to

Additionally, we were in the office last week and today we are working from home and we have noticed that maybe pulling is a bit faster but doing a commit is about the same. Saving the project still takes about 40 seconds. It takes a while to go through the steps: Locking Files, Checking for invalid files and Syncing to lastest, which is usually stuck in 99% for a bunch of seconds.

Importing audio files is also super slow, takes minutes even for very small files.

Probably the SVN integration would be usable if saving and importing was as fast as usual but at the moment is not. Using the same server and Tortoise SVN, doing commits and pulls is quick, by the way, it only seems slow when working with Fmod Studio.

That is very strange. I can’t see anything out the ordinary from the logs you have provided, but could you please attempt the IPv4/IPIv6 solution mentioned in your previous link to see if that does help? You are experiencing all the same symptoms so it might be possible there is a setting we’re not seeing.

Little update: I have not been able to apply the solutions that appear on the docs, they always seem to be syntactically wrong on the command line. An example of how the solution might look like would be nice. I also checked on tortoise SVN and it seems like I was already using the IP and not the domain version of the repo address. That’s assuming SVN is using IPV4 which is what IT tells me but I’m not 100% sure. I also tired the IPV6 solution and was getting errors, I think it was the syntax when specifying the paths.

In any case, we found a workaround that I think is good enough for anyone having these issues. We just use regular tortoise SVN and pull/push commits using that. As long as we are not working on the same events or mixer groups, we don’t conflict and that’s seems to be good enough for now.