SVN not connecting in FMOD Studio 2.00.03

Heylo FMOD Forums -

We just upgraded our Unity project from FMOD version 1.XXXX to 2.XXXX and also updated FMOD Studio to 2.00.03. With the upgrade to FMOD Studio to 2.00.03, we are now seeing SVN issues when attempting to connect within FMOD Studio. All SVN settings, project info, etc are properly input but FMOD Studio is continually considered offline. How do we go about resolving the offline issue?

Any information or direction would be appreciated.

Our SVN integration appears to be working correctly when we test it here, so there must be some difference in configuration between our test machines and the machines you’re running it on. Are you sure all the SVN settings are configured correctly? Do any of the machines you’re using feature a firewall or other piece of software that might be blocking FMOD or SVN from accessing the network?

Yup - all SVN settings are configured correctly. In FMOD Studio 1.XXXXX SVN worked and connected properly. But since the update to 2.XXXX, FMOD Studio has issues connecting to SVN. No Firewall or blocking software and running OSX. All SVN clients are connecting properly too.

The only special thing setup on SVN is “access” of the repo being checked against a security group membership in active directory (prompt for password when accessing repo path).

If those credentials are cached then authentication should be all set for that group.

We are getting an error when attempting to save as well:
"The project’s path “#PROJECTPATH”, could not be mapped to any location in the depot/repository.

Again, this is only an issue with 2.XXXX. 1.XXXX works fine.

That error message should normally only appear if the connection settings for the project aren’t correct. However, as you’ve said your connection settings are correct, I’m not sure why it’s appearing for you.

Are you able to send us the log file for an FMOD Studio session in which the connection error occurs? It may reveal information that would help us diagnose the issue. You can find the log files in the “Library/Application Support/FMOD Studio/Logs” subdirectory of your MacOS user folder. (You may need to unhide the “Library” folder.)

Where would you like this log sent? The log contains a lot of personal information - including svn passwords, logins, etc… (this personal information should be *'d out of logs to avoid credential leaks, etc).

[Scripting]runSVN: error running command: --non-interactive --username #USERNAME# --password #PASSWORD# unlock #PROJECTPATH# /Audio.fspro

[Scripting]runSVN: svn: E195013: ‘#PROJECTPATH# /Audio.fspro’ is not locked in this working copy

The easiest way to send us your logs is to select “Help > Contact support@fmod.com…” This will pop up a dialog; if you put a link to this forum thread in that dialog and click “send,” our triage team will know that it’s connected to this.

Email sent.

We have received your e-mail, but the log was not attached. To attach your recent log files to an e-mail sent through the “contact support@fmod.com” dialog, make sure the “Attach application log” checkbox is checked before clicking “Send.”

Could you please try running these two commands in Terminal, and tell us what the output of each of them is? (You’ll have to substitute in your own username, password, and project path and filename.)

svn --non-interactive --username USERNAME --password PASSWORD info "/Users/USERNAME/Desktop/Projects/PROJECTNAME_FMOD/PROJECTNAMEAudio/PROJECTNAMEAudio.fspro"

svn --non-interactive --username USERNAME --password PASSWORD status "/Users/USERNAME/Desktop/Projects/PROJECTNAME_FMOD/PROJECTNAMEAudio/PROJECTNAMEAudio.fspro"