How to disable 3d panning with 3D Sound?

Hi all!

My sound team’s designer made 3d sound events in FMOD Studio Tools.

In my situation, I’ll have to make 2d local sound with 3d sound events because lots of events are made annoy to managing events( in my projects, thousands sound events will be maked )

first, I generated 3d sound events and sync with emitter’s 3d-attributes and listener’s,
but still sounds are applied 3d panning.

Second, when I fired shot sounds continuosly, sound volume was decreased and compressed(?)

how to makes 3d sounds events are like 2d sounds events( without panning )?

Please let me know, if you have any suggestions.

I really appreciate any help you can provide.

Hi Jong,

If you don’t wish for an event to be in 3D you can simply delete the FMOD Spatializer plugin from the event.

Once an event is made 3D you can’t really “make” it 2D through code. You can try overriding the event’s default 3D min & max distance settings, however this may still sound 3D due to the upmixing to the spatializer’s output format.

I hope this helps.


1 Like