Inconsistent reverb effect between fmod studio and unreal

I am on a project using the Fmod Unreal Integration Plugin version 2.01.07 and Fmod Studio 2.01.00.

The reverb effect within unreal has an added echo when applied in unreal while having no such echo when applied within fmod studio. We eliminated as many variables as possible by playing a single sound with the effect applied in fmod studio and then in unreal with the FMODambientsound asset with the sound set in a level; there was a clear difference in how the effect was applied. Why would a difference like this occur and is there a fix?

Are you able to post a video of this happening? I’m able to get the expected reverb effect between FMOD Studio and Unreal Engine.

Here’s a video showing the inconsistency: (2021-12-12 20-22-20.mp4 - Google Drive)

I believe what’s happening is that you are spatializing the reverb along with the event. So the further away you are from the event instance, the less you will hear the actual reverb.

Can you try to replace the on-event reverb with a reverb snapshot? To set this up:

  • Add a pre-spatializer send to a return bus in the mixer (call the bus “Reverb”)
  • Add the reverb effect pre-fader in the return bus. Set the return bus fader to -oodB (mute)
  • Create a snapshot (called “reverb snapshot”) and scope in the reverb return bus, set to 0dB
  • In game, whenever reverb is needed, create the snapshot instance and play it the same way as an event instance, or using reverb zones

You can read more about reverb zones in Unreal Engine in our documentation:

This would only be an issue with the footstep sound in the example but there is still an added echo with the menu sound.

You can route the menu sound into the same reverb bus. If you want to change the kind of reverb being used whilst in the menu, you can utilize snapshots to also change these settings. See the cave and sewer reverb snapshots in the Examples project to see this in action.

Okay, We ended up fixing the issue by updating both fmod and fmod integration in our project to the newest version. It seems the issue was a change at some point in how the reverb effect is applied.