Issues with not all parameters changing from BP.


Edit: I’m on UE4.10, and FMOD Studio 1.07.03

Hi there!

I have a Footstep event which is working great. However I have two Sends on the master: forest IR, and a cavern Reverb.

Basically, The footsteps have a Surface Parameter that chooses the sound. that parameter works fine.

I have a second one called Area, and it just doesn’t work.

In the Blueprint, I have a simple Boolean set for “isincavern” that routes the BP to the Event Instance Set Parameter node correctly.

It’s linking to the same exact footstep Event Play at Location node, and the Parameter name is correct.

When testing walking through trigger boxes with debug on, I can see the nodes lighting up all the way to the last, so it should be changing just fine… ???

Do events not handle more than one parameter change at once in UE4?



This looks like it should work. To help debug it, run in Play-In-Editor mode, and try connecting with FMOD Studio. Then record a profile session.

You should see the event instances in the lifespans view as grey bars. If you click an instance you can see its parameter values as a dial, and even right click them and graph them in the profile view. This can show whether the values are changing or not.

That will isolate whether the parameter is being set into FMOD or not. If the parameter isn’t changing, then it may be that the event instance isn’t being passed into the blueprint function correctly. Or the instance may have stopped already - in that case you can add a sustain point on the event’s timeline to make sure it doesn’t finish up automatically.

1 Like

Good Idea, I’ll try the Sustain soon. (EDIT: tried, didn’t change)

I tried to connect for the profile, but it doesn’t seem to want to actually connect…

I must have missed something?

From the video, the red window means Studio did connect! But to record a profile session you must first create a profile, then hit record. If you just press record without creating a session first, nothing will happen.

I’ll make a note for the Studio team to make this workflow more clear!


Trying now…

Edit: alright, that obviously worked.

Still not seeing the change in parameter exactly. Part of me is thinking it must be the Blueprint layout, but it’s obviously pushing through already! hmm.

Thank you by the way so far. :smiley:

Hi Cory, thanks for recording a new video using the profiler. Its good feedback about how intuitive it is - for example there are categories at the top you can click to change all the views at once (e.g. lifespans), I guess it isn’t obvious that its clickable. Anyway, I can see that there over 50 instances of the footstep being created, and as it goes on more are created. Do you intend to create that many? If not look to what is creating the instance and make sure they aren’t triggered too many times. Normally you can create one instance and set the parameter on that one instance.

Hey Geoff,
Thanks for pointing that out. I definitely did NOT want 221 Instances eating my CPU. hahaha. will set polyphony to something like 6. which has me thinking that Area change really would have to happen before or to the side of the actual “play Event” bit.

Figured out my problem. I accidentally completely forgot about a temporary test BP that was setting the Cavern Bus to 0… can’t believe it.

it was sitting in the Level Blueprint, so basically everything works now as shown.

thanks again Geoff for your help!