No sound in Unity Desktop Build

My game and the FMod audio works perfectly fine when playing it in the editor, but when building it and exporting an .exe file there is no sound despite the game running as it should aside from that. I can’t seem to find a clear instruction on how to export your game along with FMod and I’d really appreciate a guide.

The way I got FMod set up in Unity is by using the ‘Project’ connection option in the settings and ‘Streaming Assets’ as import type. When building the game for Desktop I use Windows as the target platform and an x86 architecture. Then I hit build and run, but as stated earlier, the sound is absent. Any suggestions?

If you create a build using the development build option, the game should produce a log file (fmod.log), have a look for errors or warnings in that.

1 Like

Oh, here we go!
“SystemNotInitializedException: FMOD Studio initialization failed : Loading plugin ‘fmod_distance_filter’ from ‘C:/Users/Jonas/Desktop/GameProject/Game_Data/Plugins/fmod_distance_filter.dll’ : ERR_FILE_NOTFOUND : File not found.”

I assume this is connected to the plugins I have manually added in the Fmod options within Unity (two dll files for distance filter and gain) because I was told it might solve another issue. It turns out that this was the issue all along and now the sound is working!

You’re the best, Cameron