Audio in editor, but not build


I apologise for how broad a question this is, but are there any common pitfalls that might cause FMOD Unity Integration to play audio fine in editor, but for no audio to play in a Windows or Mac build of the game?

I have followed the steps as described in the documentation here:

Just to reiterate, audio plays and is triggered correctly in the editor, but when I come to run the game no audio is played and it is not possible to connect FMOD Studio to the built game. I am running Unity Pro. I have added FMOD_LIVEUPDATE to Scripting Define Symbols.

Any guidance much appreciated!

I can confirm that we have seen issues with OSX 10.6 and lower, we have reproduced the issue but have not found a solution yet. We are documenting it as a known issue for the time being, I am sorry for the inconvenience.

To those working on macs: It seems that FMOD Unity Implementation doesn’t work on Snow Leopard (10.6.2 and below). Neither at the editor, nor as a standalone build. It gives a runtime error, something like “couldn’t load libfmodstudio”.

metaphysician, take a look at this post:


Hi, I’m having the same issue…

1 Like

I had the same issue and managed to solve it by manually copying the fmod.dll, fmodstudio.dll and fmod_distance_filter.dll files to the root folder of my standalone build.

It happened to me, but I fixed it by disabling the LIVE_UPDATE from my global defines. I’m using OSX 10.9.2
Also, there’s something that is bothering me… My game is targetting the PC platform, and I won’t release it on mobile platforms, so I removed the ios and android folders. The audio didn’t work, and reading the logs I realised it needs the .so files from the Android folder. If those files are needed in other platforms, they shouldn’t be under a specific platform folder, imho.

What’s happening to me is that when I build the project and open it in my own computer (that has a windows vista installed on it) it plays fine. But if I copy it to another computer and open it it doesn’t play any sounds… I’ve tried on Macs as well, but it’s the same situation.

I get variants on this same behavior in my school where i’m teaching FMOD Studio with Unity integration. it seems to be related to some kind of path preservation. i can integrate everything fine here at home and can test it in an app build, but when i bring the setup anywhere else a wide variety of unpredictable things can happen. one issue i had was in updating the integration to a newer version. it didn’t work but gave the appearance of working until you went and built. then you got a ton of NullRef errors. i found out i had to delete all traces of the previous integration (including the the libraries installed outside the Assets folder) and install the newer one from scratch. other students had similar unstable issues going back and forth between home and school. this was in updating integration from 1.03.01 to 1.03.06.

frankly, i’m a bit frazzled - i’m going to do some more testing to see if i can narrow down the issues, and if i can’t get to a repeatable method, i’m going to put off teaching it or recommending it until it’s more stable. it’s not even remotely close to prototype ready for me, much less production ready.

When I run a development build the following error is shown:

The error does not appear when the FMOD Studio Event Emitters are removed.

HI HiFiHair,

Please send your Unity project and your FMOD Studio project through to and I will take a look.

Was the issue ever resolved? This sounds like the exact same problem im having with my Unity/Fmod Studio project. Audio works fine in editor but i get no audio in build.

No unfortunately the incompatibility with OSX 10.6 and lower is still a known issue.

I’m experiencing the same trouble as HiFiFair.
Suddenly Unity is unable to retrieve my sounds.
Could you maybe shine some light on this, Peter?

I’m experiencing the same trouble as HiFiFair.
Suddenly Unity is unable to retrieve my sounds.
Could you maybe shine some light on this, Peter?

Unfortunately we still haven’t found the cause of the incompatibility with OSX 10.6.