Programmer Instruments in Quest

We are trying to use a programmer instrument for VO in the Oculus Quest. This is working in Unity editor but when running in build the callback is not being called and we are getting the following error.

“[FMOD] ShadowEventInstance::createProgrammerSound : Programmer sound callback is not set for instrument”

Unlike other posts I have found, we’re not experiencing any crashes, just silence from the Programmer Instruments. All other FMOD events are playing without error.

Unity 2022.3
FMOD 2.02.13


Thank you for the information.

How are you triggering the programmer sound? We have a scripting example that outlines using programmer sounds for VO in Unity here: Unity Integration | Scripting Example - Programmer Sounds. Are you using an FMOD Studio | Audio Table or are you playing the VO from files?

Hi Connor,
Thanks for your reply.

We are using the scripting example you list. It worked without issue giving us hope that Programmer Instruments might be a really valuable pipeline for swapping out VO files in the future.

We are using an Audio Table (Streaming Assets/VO) , no problems or errors there. We can trigger and hear the VO files through the Programmer Instrument but only in Unity Editor, not in the Quest. All other FMOD events are playing without issues or errors.

I look forward to your reply as this is increasingly urgent! Thanks!


Good to hear the example worked, was that on the Oculus?

Would it be possible to get a full log when the programmer instrument is not working? Checking that the FMOD Integration Settings Logging Level is set to Warning:

Hi. We had advanced logging on the whole time. Thankfully we found the problem and have fixed it. For the rest of you FMOD lovers, it works swimmingly on Quest including Programmer Instruments!

Thanks for your support.

1 Like