Programmer Instrument not working in UE4.27

We are using FMODStudio 2.02.06 and trying to add localization and programmer sound/instruments to our project. We followed the documentation for how to create a localized bank with audiotables. We’ve set-up the keys and all that. When we try to play the events inside of Unreal we don’t hear anything. While experimenting with the event by adding single instruments in it’s timeline, we found out that it does play the event as we could hear every single instrument. It’s just that the Programmer instruments don’t seem to produce any sound outside of FMODStudio.

Do we need to change certain settings that’s not been mentioned in the documentation?

Hi,

Unfortunately, I was not able to replicate the issue.

Are there any errors being logged by FMOD? You can check the level of logging in the Project Settings -> Plugins -> FMOD Studio -> Advanced -> Logging Level. Setting this to Error will show us if there are any issues when trying to play an audio file from the audio table.

I actually came to the forums specifically to ask about this issue.

I have pretty much the exact same issue.

I created an event with a programmer instrument, setup an audio table with it’s own bank and built it, but when I try to trigger it in editor, no sound at all.

Here is an image of my fmod project with the relevant stuff

and my blueprint

Originally I was worried that I was just doing something wrong, but it seems someone else has the exact same problem.

But I am in UE5.0.3 So this seems to be an issue either in the way we are doing this, or an unreal issue.

You will want to extend the time of your Programmer Instrument in your event as it will only play as long as the playback position is over the instrument.

Are you receiving any errors in the console? Is it also possible to run an Profiler session to see if the instrument is being created correctly?