Selecting event in Play Event Attached is immediately clearing

Hello,
(UE 4.27 and FMOD 2.02.06)
I am maybe missing something obvious here, but I’m trying to play an fmod 2d event in my Thirdperson anim blueprint (footsteps triggered from an anim notify event) - and I am using ‘Play Event Attached’ which correctly shows a list of fmod events.

When I select an event from the list, the selected asset just remains cleared and nothing is selected - so no sound is able to trigger obviously.

(This is the same result for either Play Event 2D or Play Event Attached)

I also tried to use ‘Find Event by Name’ as input, but printing the display name at run-time just results in a blank, so I assume nothing was found.

Otherwise no issues playing fmod 2D or 3D events in my Unreal maps and no issues sending control parameter changes to fmod via blueprints that have an fmod event included as a component.

Thanks for any suggestions.

I have not been able to reproduce this issue, are the various Play Event nodes behaving correctly in the Level Blueprint and regular Blueprint Classes?
FMOD 2.02.06 is built against UE 4.27.2, perhaps you are using Unreal 4.27.1 or something like that?