Stop audio instances that are off-screen but are still active and animated in-game

As title suggest, trying to stop events triggering that are off screen.

Correct me if i’m wrong, but is that what min and max distances do?

So once the Max distance threshold is reached it will stop triggering the event?
Or is it still trigering the event but playing it at 0 volume?


Min and Max distances will only affect events with a Spatializer effect in their signal chain. Without a Spatializer an event is considered 2d and will be heard from anywhere in your game. I would suggest adding Spatializers to the events that you only want to be heard in their vicinity.

Hope this helps!

Oh sorry, my question was actually about whether audio that is outside of the min and max distance range actually stops playing.

I solved the issue actually. It turns out that it doesn’t stop the event playiung, it only turns the volume to 0.

However, in Unity, FMOD settings, under behaviour, there is a setting to specifically enable “events don’t play outside of range”.



1 Like

Apologies, you are completely right that is what will happen.

it’s all good, nothing to apologise for :slight_smile:

Just glad I randomly stumbled upon this find in Unity!

1 Like