UE4.25.4, FMOD 2.01.10 : Lookup failed for EventModel

Hi,

Recently I updated the UE4.25+ plugin from 2.01.07 to 2.01.10 version (replaced existing files instead of deleting and placing fresh files). I also rebuilt all the banks.

However, every time I select any event on a scene, there is a warning called all the time when the event is selected:

LogFMOD: Warning: c:\jk\workspace\2.1_UE4.25+_Win64\studio_api\src\fmod_objectlookup.h(122) - Lookup failed for EventModel: {Guid of event}

I also found out that every event has info and parameters tabs missing when I open them.

For now, I reverted the change and went back to 2.01.07. I use UE4.25.4.

Have you tried rebulding your banks with FMOD Studio 2.01.10 as well? If the banks were built in a different version of FMOD Studio to what the integration is then banks may not load correctly- this should pop up as a warning when you run “Validate FMOD”. Not a particularly obvious thing to try when updating, so I will see if I can add this to the troubleshooting section.
Let me know if rebuilding the banks doesn’t work and I’ll investigate further.

I wrote in my previous message that I rebuilt all my banks. And yes, I rebuilt them with FMOD 2.01.10.
I validated FMOD and everything went smoothly (I fixed all the issues that showed up).

Thanks for clarifying that for me- I have been able to recreate your issue by following the steps you provided, but building the banks in the new version of FMOD Studio after opening Unreal. Can you please verify if this is what’s happening in your case too?
If so, I was able to get rid of the warnings by rebuilding the banks in FMOD Studio while Unreal was open.
If that doesn’t work for you I will need a little more info about your setup/workflow:

  • Is the FMODStudio plugin in your engine folder or project folder?
  • When you open your FMOD Studio project, are you right clicking on the .fspro file and going “Open with>FMOD Studio 2.01.10” or are you opening FMOD Studio 2.01.10 and then going “File>Open…><path_to_file>”?

Yes, the problem appears when I rebuilt the banks with UE4 opened.
However, it turned out that when I rebuilt banks with UE4 closed and then tried to validate the FMOD in UE4, it shows a popup that loading banks failed, so the problem might be deeper than I thought.

Project folder.

I open FMOD Studio, and in the window at the beginning I choose the project file from recent projects.
image

One thing I noticed is that you are using the 4.25+ integration in UE4.25.4. These are actually two separate incompatible versions. Please double check that you are downloading the correct integration based on your version of Unreal, in your case the UE4 Standard 4.25 Windows integration.

Other than that, the only other thing I can think of would be to change the Bank Reload Delay in the plugin Advanced Settings to make sure banks are having enough time to reload after building. More details are in the Settings section of the UE4 docs.

Yes, I’m using FMOD for 4.25+ because my clients are using 4.25+ for building (not only for current gens, but also PC).

However, I checked it on different project, installed FMOD 2.01.10 for standard UE4.25 and tried validation: it failed to load banks and the “lookup failed” problem appeared. However, the events and buses were visible in the Content Browser (but they had no data in the asset editor window in the info and parameter tabs).
When I rebuilt banks and UE reloaded them, the problem disappeared, but it might be annoying to reload the banks everytime I load UE.
For now I’ve decided to stick with 2.01.07 because it doesn’t do any problems with my project.