Weird looping issue in Fmod + UE4

Hi there !

Working with Fmod and UE 4.22 and I have a weird looping issue.

Basically what happens is the first time my sound loops, it clicks, but only while playing in the engine, not in fmod and not in my DAW, and only on the first loop, after that initial click everything is working just fine.

I tried to add small fades in my asset, and pretty much every stupid idea that crossed my mind but nothing changed ^^

Edit : I would like to specify that this loop is triggered through an event instrument nested in another event via a sustain point.

Are any of the instruments synchronous? How and when is your banks’ sample data being loaded?

How are you triggering an instrument with a sustain point?

All the instuments are synchronous, and when I set them to Asynchronous they start clicking even in fmod and don’t loop properly.

My banks are separated so I have a master bank and several other banks. The event is in an ambiance bank.

The event’s setup is as follows :

If you wait for a short while after selecting the event and before clicking the play button in the transport bar, does the click occur?

I ask because FMOD Studio loads the sampledata for an event into memory when you select that event in the events browser - so if you click the play button too quickly, the event might start playing before the sampledata is fully loaded. Nonstreaming synchronous instruments in your event can’t start producing output until their sampledata has finished loading, so such instruments may begin playing their content a little late - and, as a synchronous instrument plays the part of its waveform that’s overlapped by the timeline playback position, starting a little late means it’s likely starting with a part of the waveform that isn’t a zero crossing, which might explain the click you’re hearing.

In-game, the FMOD Engine loads audio differently, so this click will not occur.

The thing is the click happens only in the engine and only on the first loop.

But I fixed it by reducing the size of the loop. I was 16sec long and I reduced it to 8sec. I guess the full setup + the long asset to load was a bit much

It’s good to hear that you’ve resolved the issue.

If you’re ever looking for an alternative way of dealing with the issue, you may want to change how and when your game loads banks. For information on that topic, see the Loading Banks Within Unreal section of the User Guide chapter of our UE4 Integration manual.

Thanks Joseph, I’ll check it out because in the end… It’s not fixed aha I thought I managed to fix it but no :sweat_smile: