4.27 Fmod 2.02.03 : Attempted to create a package with name containing double slashes

Hello everyone!

We have upgraded our UE project to 4.27 and fmod plugin from 2.02.00 to 2.02.03.
After we packaged a build and try to run the game, we get a crash indicating a wrong path where “/Game/” is added to our ‘ContentBrowserPrefix’ setting in the project/plugin settings.

[2021.09.22-09.54.23:403][  0]LogWindows: Error: Fatal error: [File:C:/Epic Games/Engine/Source/Runtime/CoreUObject/Private/UObject/UObjectGlobals.cpp] [Line: 609] 
[2021.09.22-09.54.23:403][  0]LogWindows: Error: Attempted to create a package with name containing double slashes. PackageName: /Game//Game/FMOD/PrivateIntegrationData/BankLookup
[2021.09.22-09.54.23:403][  0]LogWindows: Error: 
[2021.09.22-09.54.23:403][  0]LogWindows: Error: 
[2021.09.22-09.54.23:403][  0]LogWindows: Error: [Callstack] 0x00007fffeeed4f99 KERNELBASE.dll!UnknownFunction []
[2021.09.22-09.54.23:403][  0]LogWindows: Error: [Callstack] 0x00007ff7bceffe46 !ReportAssert() [C:\Epic Games\Engine\Source\Runtime\Core\Private\Windows\WindowsPlatformCrashContext.cpp:1644]
[2021.09.22-09.54.23:403][  0]LogWindows: Error: [Callstack] 0x00007ff7bcf040d8 !FWindowsErrorOutputDevice::Serialize() [C:\Epic Games\Engine\Source\Runtime\Core\Private\Windows\WindowsErrorOutputDevice.cpp:78]
[2021.09.22-09.54.23:403][  0]LogWindows: Error: [Callstack] 0x00007ff7bcc539cd !FOutputDevice::LogfImpl() [C:\Epic Games\Engine\Source\Runtime\Core\Private\Misc\OutputDevice.cpp:61]
[2021.09.22-09.54.23:403][  0]LogWindows: Error: [Callstack] 0x00007ff7bd2fd59b !CreatePackage() [C:\Epic Games\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp:612]
[2021.09.22-09.54.23:403][  0]LogWindows: Error: [Callstack] 0x00007ff7bb2bb8dc !FFMODAssetTable::Load() [D:\workspace\UnrealProject\Plugins\FMODStudio\Source\FMODStudio\Private\FMODAssetTable.cpp:44]

Our FMOD defaultEngine.ini
Bank Output Directory: FMOD
Content Browser Prefix: /Game/FMOD/

Our Packaging project settings:
Additional Asset Directories to Cook:
Non-Asset Directories To Copy:

I tried builds with and without the “/Game/FMOD/PrivateIntegrationData” but it doesn’t help. Also removing the /Game/ does not work and always requires it.

Unfortunately there was an issue with our 2.02.03 release for Unreal. We’ve already fixed it and put up a patched version. Please download the fixed version (it has the “patch1” designator).

You may need to delete the content browser prefix line out of your DefaultEngine.ini and delete /Game/FMOD/PrivateIntegrationData from your Additional Asset Directories to cook.

1 Like

That fixed our issue! Thanks