Allowing FMOD Events to respect Ambient Volumes

We already know that FMOD Events fired from things like PlayEventAttached do not respect Ambient Zones in Unreal. The problem is we use BPFLs to fire events at locations based on our own collision handler that calls a PlayEventatLocation function. We can’t use FMOD Audio Components on a BPFL since it’s meant to remain generic.

We need Ambient Zones to be respected since we’ll have many objects moving around between zones, none of which have Audio Components on them rather they call and fire from our helper audio BPFL.

Is the only solution to attach an FMOD Audio Component onto every single actor that should be respecting Ambient Zones? Is there a reason FMOD Events do not respect Ambient Zone settings?

My answer may be completely off, but… doesn’t it resolve the problem by creating an audio component at runtime with Add FMOD Audio Component?