FMODAmbientSound not playing until I hit Play

Howdy,
when using UE4 built in Ambient Sound I can hear it while editing the level - this way I can properly place them on the level.
When Using FMODAmbientSound I can’t hear that sound until I go to PLAY mode and test the level.

Is there a way to make FMODAmbientSound to play while in edit mode and respond to camera distance like it is with the built in UE4 CUEs ?

regards
Lukas

You can audition the event using the ‘Play’ button in the FMODAudio section of the Details panel when you have the ambient sound selected, but this won’t apply any distance or orientation effects (the in-editor auditioning uses a listener fixed at the origin).

As far as we are aware this corresponds to how UE4 ambient sounds and sound cues work - you can audition them in editor but attenuation won’t apply unless you simulate or play in editor. If you’re aware of a way to have attenuation applied while working in the editor please let us know.

In either case I’ll add a feature request for this so it can be considered for inclusion in a future release.

Ambient sounds in UE4 (CUEs) are hearable in Editor mode and have attenuation applied.
That’s why I was shocked that it is still not implemented in FMOD UE4 plugin…
If You need to place number of AmbientSouds on the level and set their ranges You need to do that in Edit mode or You’ll go nuts…
This feature is a must from a Sound Designer pespective.

I agree this certainly sounds like a useful feature and I’ve added it to our tracker for consideration but I’m still not able to get UE4 sound cues to play like that in editor and I’m very curious to experience it. Are you able to describe how to enable this behavior for a UE4 sound cue?

I haven’t really used UE4’s native audio tools very much and I suspect I’m missing some setting somewhere. I’ve created a sound cue, added an attenuation node between the wave player and the output and set the attenuation to be fairly aggressive. When I place the cue in a level nothing happens, if I play the cue using the play button in the details panel it plays without attenuation and doesn’t respond to moving around in the editor.

Please do the following:

  1. Prepare a CUE with the soundwave looped and an attenuation node.
  2. Drag the CUE to the level
  3. Check that in the Settings menu You have Real Time Audio volume slider not in the left position (this is probably why You do not hear the ambient sound in the editor mode)
  4. Move camera and hear that the attenuation is applied.

If You need, I can record a video showing how to do that, but I think You will manage.

Ah, thank you, this was exactly the setting I needed to change, it certainly helps to highlight the utility of the feature.

As mentioned I’ve added a request to our tracker, now it will need to go through the process before it hopefully gets scheduled for implementation in a future release.

1 Like

Derek, is there a possibility of that feature in near future ?
Or at least possibility to use of Play Event in Blueprints while not Playing the game, but while Editing the level ?

I can’t say for certain when this will be completed, the feature request has been agreed to though, and we’ve added tasks to our tracker to implement it. It definitely won’t make our final release this year.

I was thinking. If I create ambientsound actor with a FMOD Event on it I can do to inspector and in the FMOD section of it there is Play and Stop Button. If I hit it it will play the sound…
Maybe there is a possibilit to add some methods to the API earlier than implementing this missing feature that will allow programmer to fire up the FMOD event even though game is not playing and it’s in the editor mode at the moment ? all is needed that attenuation of the sound playing will take into consideration camera position at voila we are set…
Any1 possibility like that for earlier small addon feature ?
We could add in editor BP to handle playing of the ambient sound placed on the level in the editor situation.

regards
Lukasz

The way it is currently implemented the in-editor auditioning using the Play and Stop buttons in the inspector has both the event and listener at the origin of the audioscape. Allowing the selected audio component to be panned and attenuated according to the editor’s viewport camera would be possible but it’s not completely trivial. I can add it to our issue tracker for consideration as a preliminary solution to enabling full audio in-editor but it is not feasible to be done before our final release for this year.

Do you mean using Editor Utility Blueprints described in Epic’s docs to automate using the existing Play feature? I don’t believe the functionality required to enable that is currently exposed to Blueprints but it’s an interesting suggestion.