BUG - Ambient Zone


#1

Hey guys,

I want to report a bug with the “Ambient Zone” integration. The volume changes for interior and exterior sounds work fine, but the LPF doesn’t work at all.

I tried using a “Lowpass” as well as a “Lowpass Simple” filter, but neither one is being affected by Unreal when entering or exiting an “Audio Volume”. Furthermore I tried inserting those effects on both, the audio track itself and the master channel of the event.

Can someone confirm, that the LPF isn’t working for “Audio Volumes” with the “Ambient Zone” settings enabled?


#2

I believe it’s actually a bug with the Unreal Engine. The tool tip for LPF says to type what frequency but actually when you look at the documentation it says that a multiplier is applied, with 1 being the maximum LPF. If you type in 0.5 then it will be half way on the frequency spectrum.

I’ve submitted this bug to Epic Games.

I’d prefer if you could type what frequency you want the LPF to be at rather than a multiplier.


#3

I just realised there is some sort of inconsistency. With the occlusion settings for example we can choose the exact frequency for the LPF within Unreal. But for the ambient zone we are stuck with this multiplier, that is not even working. So maybe you are right and it’s a bug on the Unreal side of things.


#4

This does appear to be a bug with the integration, after some testing it seems that the values being passed through to FMOD were incorrect.

We are close to release at the moment so I cannot add it in for 1.10.12, but it will be added for 1.10.13 and is currently on our Github if you would like it sooner.


#5

Thank you very much Cameron