Build doesn't work in Unreal Engine 4

Hi everyone !

I am currently working on a game project using Unreal Engine 4. FMOD Plugin is very useful because we drive a vehicle in the game. I want to do a dynamic car engine and I followed this video step by step :

Everything works until I have to use the engine.

I built correctly while being careful of the destination folder and in the Engine, nothing appear except a folder which was created. I can’t add a FMOD event because files are not in the engine.

Here’s a picture of “build prefences” in the software and the folder in Unreal Engine.

Thank you for your help.

1 Like

Have you tried using “Validate FMOD” in the UE4 help menu while having your Studio project open? This should link UE4 to the project and build fresh banks.

I just “Validate FMOD” in UE4 and I have still the same problem.

The project uses Perfoce for the versionning. Is there something to set up ? I saw that in FMOD Studio, there is a “Source Control” folder in “Preferences”. I try to do something with it and I post my answer.

Thank you

Here’s some update. It’s not working yet and the problem is still the same.

I made some news screenshots to explain the problem.

I’m a little confused with all this folder to set up and I hope to find a solution.

Thank you all

Make sure you have followed the steps here:

The directory you are using in Studio (/Content/WHSoundDesign) is where the bank files go.
If you look in under Unreal Project Settings -> FMOD Studio -> Content Browser Prefix, this is where the Events/Buses/Snapshots will show up in Unreal Editor (default is /Game(Content)/FMOD/).
If you change this, Unreal will need to be restarted.

Thank you. Everything works now. It was the first time I used FMOD Studio and I didn’t think to check the documentation -_-.

Thank you very much