Can't load libfmodL.dylib in Mac build from Unity5


(Tiago Melo) #1

Hi. When I make a build to Mac from Unity5, the App can’t load the dylibs.

It’s works flawless in Editor/Android/iOS.

I used in a project of my own, and a project from the FMOD page: http://www.fmod.org/download/ (Unity Tutorial Video Assets files - Rollaball demo level - completed implementation)

Operational System: OSX El Capitan 10.11.4
Unity Version: 5.3.3f1 Personal (Free edition)

Complete error:

Couldn’t open <APP_PATH>/Contents/Plugins/fmodstudiol.bundle/Contents/MacOS/fmodstudiol, error: dlopen(<APP_PATH>/Contents/Plugins/fmodstudiol.bundle/Contents/MacOS/fmodstudiol, 2): Library not loaded: @rpath/libfmodL.dylib

Referenced from:
<APP_PATH>/Contents/Plugins/fmodstudiol.bundle/Contents/MacOS/fmodstudiol

Reason: image not found


(Nicholas Wilcox) #2

You didn’t specify which version of the FMOD Unity Integration you’re using. I reproduced the problem with the Rollaball demo which uses 1.07.03. It was fixed by upgrading to 1.08.03.