Convolution reverb not working as expected

I’m having an issue where the convolution reverb processing that plays in the fmod editor 2.00.08 is significantly different than the one heard at run time. UE 4.25.3, I’ve triple checked parameters are being set as expected. Signal chain is SFX->Transceiver->Reverb->Transceiver->My ears. Would transceivers cause degradation? I’ve tried multiple channel configurations, linking/unlinking channels on the convolution and using 1 transceiver instead of 2 to try a single reverb but they sound different from editor to runtime. Any clue what could be going wrong?

Hi Moose man,
Can you describe how it sounds different? Is the reverb longer/shorter or a different pitch? This could be to do with the rate of your impulse not matching the output rate at runtime.

Unfortunately impulses aren’t resampled at the moment, definitely something i’m working on now.
I have a feeling this might be something to do with it. Can you verify what platform it is running on , i’d be interested if the output sample rate was different at runtime.

Hey Brett, thanks for replying!

The reverb seems to be a different pitch or losing some quality between in FMOD and at runtime UE4(in editor and built). My sounds, impulses, and build sample rate are all set for 48k. My output is 48k via usb3 to a focusrite 18i20, the same sort of problem is happening on the other sound designers machine(fmod and UE4) as well as the rest of the team(just UE4).

My pc specs:
Intel I7-7600k @ 4.00ghz (no OC)
32gb ddr4 ram
nvidia gtx geforce 1060 6gb
Windows 10 version 1903

I would be happy to share some video with you if email or DMs are an option. I have permission from management to share stuff directly with the FMOD staff, but I can’t post the video on forums since they are semi-public.

Let me know if that illuminates anything for workarounds or fixing a problem. Thanks!

Hi ,
Please use to upload data to us, i’d be interested in maybe just the impulse and the fmod studio project, you could strip it down maybe to save space if you just have one event that you play that doesnt sound right. I could try building it and using my own getEvent code to play it back and see if it sounds wrong on my side.

Will do, awaiting approval for the project and then I will send the videos of our use as well as a stripped down project of exactly what I’m doing. Thanks for the help!

Just uploaded stuff, hopefully it helps!

thanks looking into this now

an update, i ran this in my own testbed which just plays the events in your project and it sounds identical in runtime, as in the tool.

Does this stripped down project, if you hooked it up to ue4 produce the same problem?

By the way : For it to work, I had to move the noise making event in the mixer view, into the group you set up in the mixer. There was no reverb otherwise.

Hey Brett,

I ran it with a new ue4 4.25.3 project and had no issue, sounded as I expected it to. But, I also grabbed a new version of the 4.25 integration. I’m going to upgrade our FMOD integration and see if that fixes it in the project. I’m thinking it could be the integration or maybe we are running into some weird voice starvation problems. Do you have an idea what might cause issues other than the sample rate?

Hi ,
From listening to your videos again, its definitely convolving with something, and it isnt some other artifact like stuttering or distortion. I think the reverb effect itself is ok, but there is an error with what got passed in as an impulse.

This could be to do with the integration. I’ll have to ask internally if anything to do with the way banks are loaded could have caused this?

You said originally ‘2.00.08’ , is that the version you’re talking about , and the new version you tried is 2.00.11?

Yea, I am upgrading the integration from 2.00.08 to 2.00.11 and then going to try removing limiters and other things from the FX chain if the integration itself doesn’t fix it. We are loading a lot of audio currently but we haven’t had issues with memory or anything of that nature so far.

4 4.25.3 project and had no issue, sounded as I expected it to. But, I also grabbed a new version of the 4.25 integration. I’m going to upgrade our FMOD integration and see if that fixes it in the project.

I’m interest to see how you go with the upgrade. Let me know how you go.

1 Like

I waited on the upgrade to test signal flow stuff first. Limiters were causing the weird distortion, I removed limiters entirely and it sounds as expected. Is there a feature of limiters that would cause the IR’s to sound weird? Just wondering for the next time I use them.

I would switch to the fmod compressor (or look at McDSP ML1 limiter). The FMOD limiter is being looked at at the moment as it is an effect which may need better support/fixes to make it more useable.

1 Like

Awesome, thanks for testing to confirm it wasn’t the convolution for me! I’ll move to a new limiter and start to use those.