Crossfade breaking loops?

  • I created a loop in my DAW (Ableton).

  • I split the tracks and repositioned them to create a perfect loop, with a loop region. (This worked as expected, creating a seamless audio loop)

  • I added a fade to the track and suddenly there is an audible change when the audio loops round, even though the fade is not affecting that part of the sample at all.

Is this due to some sort of processing delay? Is it just part of the editor and will “fix” itself during playback in Unity? A bug?

It depends on what you mean by fade. Is this a fade on an instrument (ie. grabbed the corner of an instrument and pulled it in), a fade on an instruments volume property (ie. an AHDSR modulator), or is this controlled in some other way?

If possible please provide a screenshot of your event in case it’s something we’ve missed.

Hi thanks for the reply and sorry for the delay. Yes, it is when dragging the corner to create a fade. Essentially, no fade, completely fine works as expected, add fade, there is an audible noise when the loop goes round.

To get around this currently I have just automated the volume instead of fading and that doesnt seen to create the same issue.

fade no fade

I’m happy to hear you have found a workaround, but I’m still not certain why the loop breaks using the fade in curves. What kind of assets are you using (mp3, wav, etc)

Thanks for getting back to me. Ill be honest I have no clue why this seems to be happening. The files are standard .wav exported from Ableton Live and I can confirm it isn’t the DAW or files I used as automating the volume at the same point where I had the fade (neither option effecting the start or end of the file where the loop occurs) does not produce the same issue. I have since changed the project but I can see if I can recreate the issue and send it over if that helps.

My post may be irrelevant, but for the sake of curiosity, what are you trying to achieve? Why create a seamless loop to put cross fades on it afterwards? Why not simply use the crossfades in the transition timeline of the loop region?

Its just the way I make loops easily, perhaps theres a better way which I would be glad to hear but essentially I make somthing in the DAW, export it as one audio file, then split it in half, put the end at the front which is seamless when it loops back around as they have the exact same volume point in the file (like a zero crossing) and then to merge the clip back together I just use crossfades in the middle. It works pretty well. It just seems weird to me that if I replace the crossfades with volume automation doing the exact same thing, that works, but fades do not.

That’s weird indeed. However, I would tend either to create a seamless loop with your method directly in the DAW before importing in FMOD, or on the other hand simply import the non seamless loop and use the crossfades in the transition timeline of the loop. Right click on the loop line, transition timeline, ajust the length, grab left and right part until they crossfade. It’s a but tricky to understand, though, and you’ll have to import a file a little longer than the loop itself to do this correctly.