DLL Shows 0.00.00 and FMOD banks won't load

I’m running FMOD Studio 1.10.12 and integration package 1.10.12 with UE 4.21.2.

I can see the FMOD help menu, so I’m pretty sure I’ve got the integration installed correctly. But the DLL is showing 0.00.00.


Also, perhaps related, I’m getting an error loading my bank into UE 4.21.2. Here’s the error message:



1 Like

Are there any errors or warnings that may relate to this at all?

I would try removing the integration, as well as a few folders from the project:

  • Binaries
  • Intermediate
  • Saved

Then add the integration and see if that helps.

@cameron-fmod I have the same error with FMOD 2.02.02 and UE 4.26.2. I removed the integration package from the engine, reinstalled both the UE and FMOD, then added the integration but it doesn’t help, the error keeps showing up :frowning: Please advise if you know the direction. Thanks!

What errors are you seeing?
Are you able to share your output log?

Here are the screenshots of the errors as well as the log. If you have any suggestions, please let me know. Thank you so much!
Log.log (246.5 KB)

It looks like the FMOD system is failing to initializa due to

LogFMOD: Error: ... IMMDevice::Activate returned 0x88890004.  Device was unplugged!

Is this occurring over Remote Desktop by chance?
Also you can enable more logging by changing the logging level in the UE4-FMOD settings, using level Log will provide a lot of information. Can you please share the log after changing the logging level?

No, this is not Remote Desktop. The files automatically are backed up in OneDrive, can this be the cause of the error?

As for the audio output device, I occasionally switched between the laptop soundcard and an external Audient soundcard, but not while working on the project.

Here is the Level log.

log_level.log.txt (68.6 KB)

Thanks very much for the logs!

It appears to be caused by anything that invalidates the audio device, not just Remote Desktop, we are currently looking into a fix for this.

Does this occur every time you open the project or only at specific times?

Disabling the options in the FMOD Settings for Match Hardware Sample Rate should stop this from occurring in editor.

I disabled the Match Hardware Sample Rate option. Unfortunately, it didn’t help :frowning:

I’m sending you the log just in case. log.log.txt (61.5 KB)

Later I re-installed the integration package and created a new project with this option disabled, didn’t help.

This occurs at every project’s startup and later if I build banks or validating FMOD.

Is there a chance for a fix? Or should I just re-install the system?

Update: I tried to create an UE project without FMOD, still no sound. After that, I deleted all audio devices except the Reaktek sound card. Reinstalled the integration package, everything works now! Apparently, there were conflicts between audio devices on the machine.