DllNotFoundException: fmodstudio.dll

Really need help with this. FMOD works great in the Unity Editor, but if I make a standalone build on Windows 7 both 32bit and 64bit, it fails to load the fmodstudio.dll

I have fmodstudio.dll in the Plugins folder inside my Data folder, the build process is putting it there correctly.

I get the ‘Fallback handler could not load library’ message several times in the output log with the paths it is checking for fmodstudio.dll, and then at the end is the DllNotFoundException as seen below:

DllNotFoundException: D:/Proj/BrokenDimension/Unity46/brokendimension/BUILDS/WIN/RELICS_32_Data/Plugins/fmodstudio.dll
  at (wrapper managed-to-native) FMOD.Studio.EventInstance:FMOD_Studio_EventInstance_Start (intptr)
  at FMOD.Studio.EventInstance.start () [0x00000] in <filename unknown>:0 
  at AudioManager.Init () [0x00000] in <filename unknown>:0 
  at GlobalSingletonWrapper`1[AudioManager].Instantiate () [0x00000] in <filename unknown>:0 
  at GlobalSingletonWrapper`1[AudioManager].CreateInstance () [0x00000] in <filename unknown>:0 
  at GameManager.CreateAndLinkSingletons () [0x00000] in <filename unknown>:0 
  at GameManager.Init () [0x00000] in <filename unknown>:0 
  at GlobalSingletonWrapper`1[GameManager].Instantiate () [0x00000] in <filename unknown>:0 
  at GlobalSingletonWrapper`1[GameManager].CreateInstance () [0x00000] in <filename unknown>:0 
  at WorldManager.Start () [0x00000] in <filename unknown>:0 

Has the fmodstudio.dll been compiled with dependencies requiring any specific visual studio packages? I’ve tried on two computers with the same results…


Its interesting because what triggers the error is EventInstance.start()
I’m able to load my sound bank, get an event instance… but as soon as I have the .start() in there it will error out…

Strange because it looks like GetEvent and loadBankFile both are wrapped function calls into the fmodstudio.dll right?

heres the test script I’m running:

studioSystem = FMOD_StudioSystem.instance; 

string fileName = Application.streamingAssetsPath + "/Player"; 

FMOD.Studio.Bank bank; 

FMOD_StudioSystem.ERRCHECK(studioSystem.System.loadBankFile(fileName + ".bank", FMOD.Studio.LOAD_BANK_FLAGS.NORMAL, out bank)); 
FMOD.Studio.EventInstance test; 

test = studioSystem.GetEvent("{64f63fa1-8218-40fa-8053-25e037be67da}");  

//this line below causes my build to error out and stop working, if I comment it, all is good (But no sound plays of course..)  

Okay, well this looks like it might just be some weirdness with the DLL not being fully loaded when I’m calling test.start();

If I try to play audio later once the game has been running ( 10-20 seconds after load ) all is good and the audio plays through FMOD.

Kinda strange, but it looks like things are working.

Experiencing the same strange time delay of 20 seconds for events to be audible, but this is happening inside the Unity editor, haven’t tried to make a build and test. Using FMOD Studio and Unity Integration 1.05.00.