DllNotFoundException: fmodstudioL after BuildFailedException Fix

Hey all!

Been in the process of migrating from 1.10 to 2.1.11. Got everything working great in the editor.

I got an error when I tried to build
-BuildFailedException: There is an FMOD binary missing for build target StandaloneWindows64

I followed the steps to fix that based on an older forum post here.

  • I deleted the “\Assets\Plugins\FMOD” folder with Unity closed.
  • Opened it back up
  • Re-Installed the integration Plugin

Now, I am receiving this error

-DllNotFoundException: fmodstudioL

and I cannot run the project in the editor at all or use the FMOD event browser. I tried reimporting everything, refreshing the FMOD assets. That DLL does exist in my project under the x86_64 folder. I dunno what to do. If anyone has any ideas, I would be extremely extremely grateful. Hope you all are having a great week.

It appears Unity was doing something goofy and not importing the full package. The fix was create a new empty project, import the integration package, then drag over all the files to the live project. Worked like a charm!